Search found 55 matches

by emarcotte
Sun Sep 26, 2010 15:24
Forum: Help
Topic: [Solved] Crash adding to listbox
Replies: 2
Views: 761

Re: Crash with OGRE 1.7 and CEGUI 0.7 (svn) adding to listbox

This has been solved (With CE's help, on IRC). The change to demo7 was incorrect itself. My own project's crash was different as I was attempting to add items on a non-rendering thread. I believe this worked previously because I did not have the auto-rendering-surface stuff enabled until recently, a...
by emarcotte
Wed Sep 22, 2010 23:46
Forum: Help
Topic: Setting Ogre dir on Linux
Replies: 11
Views: 2306

Re: Setting Ogre dir on Linux

yeah sorry i meant _PATH, I was at work and not in front of a real computer to test it :)
by emarcotte
Wed Sep 22, 2010 13:04
Forum: Help
Topic: Setting Ogre dir on Linux
Replies: 11
Views: 2306

Re: Setting Ogre dir on Linux

The lua build stuff is for premake which is for windows (as far as I've ever used it, anyway) For linux, use the autoconf things like you have. What you need to do to find ogre is either use pkg-config or use Ogre_CFLAGS and Ogre_LIBS (I forget the exact names, but something like that). Using pkg-co...
by emarcotte
Wed Sep 22, 2010 00:20
Forum: Help
Topic: [Solved] Crash adding to listbox
Replies: 2
Views: 761

[Solved] Crash adding to listbox

Hi, I've had this for a while, but *finally* got around to reproducing the crash in a demo (rather than my own app where it could be all my bad!). Basically what I want to do is have items get added to a listbox in an event callback. This worked a couple months ago, and it works on Windows (I believ...
by emarcotte
Fri Sep 17, 2010 14:25
Forum: Help
Topic: Build CEGUI with MinGW+MSYS?
Replies: 11
Views: 1308

Re: Build CEGUI with MinGW+MSYS?

OGRE doesn't generate the pkg-config files on msys (I've attempted a couple of times to fix this but never got it working 100%). I usually send up telling CEGUI about ogre using Ogre_CFLAGS, etc.
by emarcotte
Fri Sep 03, 2010 10:26
Forum: Modifications / Integrations / Customisations
Topic: [solved] About ways to use Animation System
Replies: 9
Views: 1584

Re: About ways to use Animation System

I think the 'expected' approach would be to define the animation like you would in the animation/looknfeel xml, then reference it via code. Layouts are sort of like instantiations of the looknfeel's so you shouldn't really be defining the looknfeel in the layout :) I could see it being useful to ref...
by emarcotte
Tue Aug 17, 2010 11:21
Forum: CEGUI Library Development Discussion
Topic: API breaking consistency fixes intended for CEGUI 0.8.0
Replies: 50
Views: 10734

Re: API breaking consistency fixes intended for CEGUI 0.8.0

I don't know which namespace style I like more, it is true there are more namespaces out there all lower case, but then again, there are also many with upper case (Ogre, Poco project, others I can't remember off the top of my head). ctags is smart enough to autocomplete it either way in vim, so I do...
by emarcotte
Thu Aug 12, 2010 12:42
Forum: CEGUI Library Development Discussion
Topic: Generic animation support for CEGUI::Window
Replies: 35
Views: 6933

Re: Generic animation support for CEGUI::Window

I just wanted to say that this API is really nicely presented from the little sample you gave on IRC. I slapped it onto one of the CEGUI demos and it definitely makes things feel much more "shiney" with very little effort.

Awesome work to all involved. :hammer:
by emarcotte
Wed Aug 11, 2010 10:40
Forum: CEGUI Library Development Discussion
Topic: Generic animation support for CEGUI::Window
Replies: 35
Views: 6933

Re: Generic animation support for CEGUI::Window

Could you include links to the patch you listed on IRC? I was going to try it out on another box to see if my app had the same issues with textures being all weird after animation. I suspect (though I'm still not sure, need to try some other stuff) that it has to do with how I am bootstrapping OGRE ...
by emarcotte
Fri Aug 06, 2010 14:22
Forum: Help
Topic: How to run CEGUI with Irrlicht
Replies: 7
Views: 1296

Re: How to run CEGUI with Irrlicht

Looks like you're not linking to the render module perhaps? You need to link to both CEGUIBase and whichever module you use.

Edit: I'm a moron. I didn't notice the pragma for libs. Nevermind me.
by emarcotte
Fri Aug 06, 2010 11:29
Forum: Help
Topic: cannot compile dll,lib
Replies: 2
Views: 381

Re: cannot compile dll,lib

There is a broken link on that page, but it should link to http://www.cegui.org.uk/docs/current/compiling.html Ultimately you need the dependencies listed there. For visual studio (I'm guessing thats what you use) you can find a pre-compiled dependencies package at http://www.cegui.org.uk/wiki/index...
by emarcotte
Thu Aug 05, 2010 12:03
Forum: Help
Topic: Custom Skinning
Replies: 1
Views: 320

Re: Custom Skinning

Absolutely possible, and depending on what you do it is usually pretty easy. http://www.cegui.org.uk/skins/ has a couple, but they may be out of date with the current version of CEGUI. Currently there are a couple of parts you need to play with to do it, however. Basically a 'skin' is a combination ...
by emarcotte
Wed Aug 04, 2010 11:00
Forum: Help
Topic: Deployment & OgreRenderer
Replies: 18
Views: 1599

Re: Deployment & OgreRenderer

I would double, triple, quadrouple check that the DLLs you're using when running in VS are the same as when not. I've done this a billion times... copy CEGUI dlls into visual studio's build directories build, test, etc then forget to copy the dlls to my 'deployment' area.
by emarcotte
Tue Aug 03, 2010 11:00
Forum: Help
Topic: Deployment & OgreRenderer
Replies: 18
Views: 1599

Re: Deployment & OgreRenderer

Do you try {... } catch (..) {...} around bootstrap? Quite often an exception is thrown and the default catching mechanism on windows isn't going to tell you all the details. That's always the first place to start when debugging this sort of thing. More than likely, however, you have dlls in a place...
by emarcotte
Mon Aug 02, 2010 10:35
Forum: CEGUI Library Development Discussion
Topic: CMake build script for MinGW
Replies: 1
Views: 2176

Re: CMake build script

Nice. I'll have to try this. I went through installing msys so I could run configure.

Go to advanced search