Search found 16 matches

by Stefan Lundmark
Tue Nov 03, 2009 21:02
Forum: Help
Topic: Dramatic performance differences between 0.6 and 0.7.1
Replies: 2
Views: 812

Re: Dramatic performance differences between 0.6 and 0.7.1

That does look interesting, but I can't find any documentation on it (not about GeometryBuffers either). I'm not using the Window class but drawing from ImageSets as the OGRE example shows. Thanks for chiming in! Edit: Don't reallocate a texture each frame. That's what I was doing. Yup, I'm embarass...
by Stefan Lundmark
Tue Nov 03, 2009 19:53
Forum: Help
Topic: Is anyone *really* statically linking to CEGUI?
Replies: 4
Views: 1259

Re: Is anyone *really* statically linking to CEGUI?

Hi scriptkid, I'm obviously linking to the correct lib since between changing those lines and recompiling CEGUI, there's nothing else I've done and it works just fine after the commenting out those defines. I have to admit I haven't tried the samples though. I'm considering switching back to 0.6 and...
by Stefan Lundmark
Tue Nov 03, 2009 19:29
Forum: Help
Topic: Dramatic performance differences between 0.6 and 0.7.1
Replies: 2
Views: 812

Dramatic performance differences between 0.6 and 0.7.1

Edit: Read last post, there's (as usual) no problem with CEGUI but how I use it. I was never in doubt! ;) ORIGINAL POST: I'm seeing dramatic performance differences between 0.6 and 0.7.1. I use Image::draw () to draw a button that has one texture when depressed and another when hovered. In 0.6 it w...
by Stefan Lundmark
Mon Nov 02, 2009 21:55
Forum: Help
Topic: Drawing a geometry buffer with alpha enabled?
Replies: 3
Views: 903

Re: Drawing a geometry buffer with alpha enabled?

So you are saying the TIFF loader for OGRE doesn't support alpha? That seems odd since the TIFF format has been around for quite a long time. Thanks for the heads up though. LibTiff doesn't like the garbage that Photoshop sometimes can produce when writing TIF files with layers or metadata. It's pa...
by Stefan Lundmark
Mon Nov 02, 2009 01:03
Forum: Help
Topic: Drawing a geometry buffer with alpha enabled?
Replies: 3
Views: 903

Drawing a geometry buffer with alpha enabled?

I'm trying to get a GeometryBuffer to be drawn with alpha enabled, ie the textures that are transparent should be when they get rendered. Currently they're showing up white where they should be showing the background. Let me know if this is too vague, I just haven't found any documentation regarding...
by Stefan Lundmark
Thu Oct 29, 2009 22:13
Forum: Help
Topic: Is anyone *really* statically linking to CEGUI?
Replies: 4
Views: 1259

Re: Is anyone *really* statically linking to CEGUI?

CEGUI version 0.7.1 but I'm pretty sure I had to do the same change for 0.6x. I haven't tried the samples (did a fresh new project in MSVC but it failed with the same linker errors) as it's working now with the changes I described in my first post. Just wanted to write it down incase someone else ru...
by Stefan Lundmark
Thu Oct 29, 2009 12:05
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [SOLVED] Crash when initializing CEGUI/Ogre
Replies: 3
Views: 2188

Re: Crash (with nothing in the log) when initializing CEGUI/Ogre

Just found out that the System object is created inside the bootstrap function.

In any case, making it clearer that the System object already has been created wouldn't hurt?

Edit: Thanks Van for confirming!
by Stefan Lundmark
Thu Oct 29, 2009 11:48
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [SOLVED] Crash when initializing CEGUI/Ogre
Replies: 3
Views: 2188

[SOLVED] Crash when initializing CEGUI/Ogre

I'm getting a crash inside CEGUI 0.7.1 when initializing it with my Ogre RenderWindow. CEGUI::OgreRenderer &renderer = CEGUI::OgreRenderer::bootstrapSystem (*mRenderWindow); CEGUI::System::create (renderer); The RenderWindow passed is correct as the game works correctly without CEGUI. This is th...
by Stefan Lundmark
Wed Oct 28, 2009 22:44
Forum: Help
Topic: Is anyone *really* statically linking to CEGUI?
Replies: 4
Views: 1259

Is anyone *really* statically linking to CEGUI?

Hi, I keep running into issues with static linking. For one, my package (MSVC 2008) simply won't link (unresolved externals) to the static libs when CEGUIEXPORT is set to either import or export, so I end up with this: //#if (defined( __WIN32__ ) || defined( _WIN32 )) && !defined(CEGUI_STATI...
by Stefan Lundmark
Sat Oct 24, 2009 19:10
Forum: Help
Topic: CEGUI_FALAGARD_RENDERER - should be defined where?
Replies: 12
Views: 1831

Re: CEGUI_FALAGARD_RENDERER - should be defined where?

Ok, thanks for the info. Is the Ogre lib also statically linked here? I ask because if I get around to testing in order to see what might cause such an issue, I want to make sure I'm working with the same set-up otherwise it's a total waste of time :) Thanks again, CE. Ogre, FreeType, FreeImage - s...
by Stefan Lundmark
Fri Oct 23, 2009 12:53
Forum: Help
Topic: CEGUI_FALAGARD_RENDERER - should be defined where?
Replies: 12
Views: 1831

Re: CEGUI_FALAGARD_RENDERER - should be defined where?

Both the first two images use precisely the same assets, the same CEGUIOgreRenderer/CEGUI but dynamically linked.
by Stefan Lundmark
Sat Oct 17, 2009 11:08
Forum: Help
Topic: CEGUI_FALAGARD_RENDERER - should be defined where?
Replies: 12
Views: 1831

Re: CEGUI_FALAGARD_RENDERER - should be defined where?

Yeah, 0.62b. The change in color is due to the gui controls being transparent and the background is showing trough, so the only issue seems to be related to how the widgets line up. Are the assets between 0.5 and 0.6b compatible? I just noticed the ones in the 0.6b samples are different in WinMerge....
by Stefan Lundmark
Fri Oct 16, 2009 22:47
Forum: Help
Topic: CEGUI_FALAGARD_RENDERER - should be defined where?
Replies: 12
Views: 1831

Re: CEGUI_FALAGARD_RENDERER - should be defined where?

I've hit a snag (again) with TaharezLook not looking quite like it did when I dynamically linked to CEGUI before. Here's a screen: http://www.fragile-online.com/cegui.jpg Is the issue obvious? I can't tell, but the background sure is the one from TaharezLook.. but the borders look way wrong. The CEG...
by Stefan Lundmark
Thu Oct 15, 2009 11:23
Forum: Help
Topic: CEGUI_FALAGARD_RENDERER - should be defined where?
Replies: 12
Views: 1831

Re: CEGUI_FALAGARD_RENDERER - should be defined where?

Hi CE and thanks for your answer, Yeah I meant to say version 0.6.2b. I've been hitting this error for a day now and it's terribly embarassing to say that you were (of course) right in that the falgard lib wasn't linked to. I have no idea how that happened as I made sure it was there before, but mus...
by Stefan Lundmark
Wed Oct 14, 2009 22:19
Forum: CEGUI Library Development Discussion
Topic: Falagard Visual Skin / Scheme Editor
Replies: 65
Views: 30655

Re: Falagard Visual Skin / Scheme Editor

Just wanted to chime in and say that I would consider $30 a small price to pay for such a tool.

Go to advanced search