Search found 1780 matches

by Ident
Thu Sep 21, 2017 17:17
Forum: Help
Topic: "default" on Ogre2.1/D3D11?
Replies: 8
Views: 30

Re: "default" on Ogre2.1/D3D11?

Ogre 2.0 and Ogre 2.1 support is entirely based on user contributions :)
by Ident
Wed Sep 20, 2017 22:17
Forum: Help
Topic: "default" on Ogre2.1/D3D11?
Replies: 8
Views: 30

Re: "default" on Ogre2.1/D3D11?

Do you mind trying with CEGUI v0-8 ? Just trying for now, because I know that different ppl made PRs on those two branches and support for Ogre may differ at this point.
by Ident
Tue Sep 19, 2017 20:59
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Thats very interesting - that it draws a black triangle. Could you please check in gdebugger if (and please do mind which context you are checking this for and if it matches the used one for drawing) the textures are properly loaded? You should be able to easily see them all in there somewhere when ...
by Ident
Tue Sep 19, 2017 20:29
Forum: Help
Topic: "default" on Ogre2.1/D3D11?
Replies: 8
Views: 30

Re: "default" on Ogre2.1/D3D11?

Cegui version? Ogre version?
by Ident
Mon Sep 18, 2017 21:39
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Wait a moment, why is the context id suddenly 4 when you render CEGUI?

The rest looks good now btw ;)

But switching the context means a lot. Do you have multiple GL contexts running? Which one was active when you initialised the cegui openglrenderer?
by Ident
Mon Sep 18, 2017 21:34
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Does CEGUI draw anything at all (even if it is black) or does it just do nothing to your screen?

Do you have the right FBO bound to render to? Is that the main framebuffer of your application window or what is it? I think your code used the fbo 0 so the main framebuffer right?
by Ident
Mon Sep 18, 2017 19:06
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Are you rendering to a MSAA target?

The OpenGL samples all either render to a simple texture target without MSAA or to the default framebuffer (swap buffer) which has no MSAA support normally either. At least I have never seen such a capability anywhere.
by Ident
Mon Sep 18, 2017 16:56
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

I see nothing instantly apparent. The diff shows that there are the changed values (new values shown here) GL_SAMPLE_BUFFERS=1 GL_SAMPLES=4 GL_VIEWPORT={0, 0, 1920, 1040} GL_STENCIL_BITS=8 GL_SCISSOR_BOX={0, 0, 1920, 1040} GL_DEPTH_BITS=24 GL_COLOR_CLEAR_VALUE={0, 0, 0.44999999, 0} You can use a pro...
by Ident
Sun Sep 17, 2017 19:12
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

That would be for the same reason yes. The state machine probably is in a state cegui cant deal with well. Since u didnt manage to clean up all opengl calls i recommend you to use gldebugger. It is for free. You do the following, you let it hit a break after opengl window creation and check the stat...
by Ident
Sun Sep 17, 2017 18:36
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

OpenGL does not support multithreading.

This might or might not be the problem. The renderer should lie on the same thread as where your other opengl calls are triggered.
by Ident
Sun Sep 17, 2017 17:17
Forum: Help
Topic: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 17
Views: 108

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Does it work if you just render CEGUI without calling any OpenGL functions yourself?

After the above, if above works, does enabling this (true) work: renderer.enableExtraStateSettings ?
by Ident
Tue Sep 05, 2017 21:16
Forum: CEGUI Library Development Discussion
Topic: Python bindings using Pybind11
Replies: 4
Views: 91

Re: Python bindings using Pybind11

Lucebac suggested SWIG http://www.swig.org/

We would have to evaluate if this helps us in any way
by Ident
Tue Sep 05, 2017 20:41
Forum: CEGUI Library Development Discussion
Topic: Python bindings using Pybind11
Replies: 4
Views: 91

Re: Python bindings using Pybind11

I dont know too much about how pybind works, it was honestly just a curious question because I dont know it myself. The binding creation seems the toughest part to me and it is quite a PITA according to Kulik, who declared it a process involving magic and him being the only one who knows how it is d...
by Ident
Sun Sep 03, 2017 07:18
Forum: CEGUI Library Development Discussion
Topic: Python bindings using Pybind11
Replies: 4
Views: 91

Re: Python bindings using Pybind11

And how would we generate the bindings for this pybind11?

Go to advanced search