Search found 35 matches

by BrightBit
Mon Sep 02, 2013 14:02
Forum: Help
Topic: [SOLVED] What happened to the Checkbox?
Replies: 3
Views: 541

Re: What happened to the Checkbox?

Thanks Kulik, indeed: Using ToggleButton instead seems to be straightforward.
by BrightBit
Mon Sep 02, 2013 00:22
Forum: Help
Topic: [SOLVED] What happened to the Checkbox?
Replies: 3
Views: 541

[SOLVED] What happened to the Checkbox?

Hello,

I am porting my project from CEGUI 0.7 to CEGUI 0.8 and noticed that the Checkbox class is missing. Is that on purpose? Do I have to use the ToggleButton instead, now?


Greetings
BrightBit
by BrightBit
Sun Sep 01, 2013 22:14
Forum: Help
Topic: [SOLVED] 'ostream' is not a member of 'std'
Replies: 1
Views: 2232

Re: 'ostream' is not a member of 'std'

I found the reason for my problem. In my build system one of the additional include directories was: "C:\InstallDir\cegui\include\cegui-0\CEGUI". However at some point during the compilation process a <cstring> header is implicitly called, that in turn looks for a "string.h" file...
by BrightBit
Sun Sep 01, 2013 11:52
Forum: Help
Topic: [SOLVED] 'ostream' is not a member of 'std'
Replies: 1
Views: 2232

[SOLVED] 'ostream' is not a member of 'std'

Compiling my own project results in the error message: error C2039: 'ostream' : is not a member of 'std' C:\Programming\Install\cegui\include\cegui-0\CEGUI\Base.h 183 My problem seems to be similar to this one on the Ogre forums: CEGUI 0.8.1 bugged? except that I am already using CEGUI 0.8.2. 1>----...
by BrightBit
Sat Aug 31, 2013 19:05
Forum: Help
Topic: CEGUI 0.8.2 w/ Ogre 1.9 compilation problems OS X
Replies: 8
Views: 4312

Re: CEGUI 0.8.2 w/ Ogre 1.9 compilation problems OS X

Hi soulstorm,

welcome to the CEGUI forums. Did you call hg update v1-9 on your Ogre source directory first?
How does your OgrePrerequisites.h look like?


Greetings
BrightBit
by BrightBit
Thu Aug 29, 2013 22:05
Forum: Help
Topic: [SOLVED] Redefinition of Ogre::TexturePtr while compiling
Replies: 2
Views: 1555

Re: Redefinition of Ogre::TexturePtr while compiling CEGUI

Hi Kulik, thank you for this hint. I forgot to call hg update v1-9 on my Ogre sources, so CEGUI's config.h looked like this: #ifndef CEGUI_OGRE_VERSION_MAJOR # define CEGUI_OGRE_VERSION_MAJOR 2 #endif #ifndef CEGUI_OGRE_VERSION_MINOR # define CEGUI_OGRE_VERSION_MINOR 0 #endif #ifndef CEGUI_OGRE_VERS...
by BrightBit
Wed Aug 28, 2013 21:54
Forum: Help
Topic: [SOLVED] Redefinition of Ogre::TexturePtr while compiling
Replies: 2
Views: 1555

[SOLVED] Redefinition of Ogre::TexturePtr while compiling

Hi CEGUI community, I got the current sources of CEGUI, Ogre and their dependencies by their corresponding repositories. Microsoft Visual Studio Express 2012 (v11) was used to compile all these sources, i.e. right now I am using Windows 7. I've compiled all dependencies and Ogre without problems but...
by BrightBit
Mon Jun 11, 2012 10:27
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

Re: Cleanup problem of GroupBox with additional AutoWindows

Great. :D You've been amazingly helpful. Thank you so much CrazzyEddie.
by BrightBit
Sun Jun 10, 2012 23:26
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

It works

Thanks in heaps. It works.

I hope this is no silly question but I am not that familiar with mercurial's branching model. Will future fixes of the 0-7 branch be integrated into the incompatible-fixes branch, too?


Greetings and thank you very much
BrightBit
by BrightBit
Wed Jun 06, 2012 15:31
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

NamedArea not updated

Thanks again. :) The NamedArea technique did work except for the fact that this area isn't updated if I change properties that are flaged with redrawOnWrite or layoutOnWrite (or both). Here's a small video to illustrate what I mean: https://www.youtube.com/watch?v=0jg3-XJg7Fc On the top left corner ...
by BrightBit
Wed Jun 06, 2012 12:56
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

Order of AutoWindows seems to be important now

Thank you CrazyEddie. :) The cleanup seems to work and the exceptions due to the "layoutOnWrite" attribute are gone, too. However, the order in which I define the AutoWindows in the looknfeel file seems to be important now. Is this the intention? For my custom GroupBox I created two AutoWi...
by BrightBit
Tue Jun 05, 2012 19:06
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

Re: Cleanup problem of GroupBox with additional AutoWindows

You're welcome as always. :) Here's another thing I noticed. I'm not sure if this is related to the "Additional AutoWindow" problem I mentioned above, so I didn't open a new post: When I add the attribute "layoutOnWrite='true'" to a PropertyDefinition AND have an additional AutoW...
by BrightBit
Tue Jun 05, 2012 14:47
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Cleanup problem of GroupBox
Replies: 12
Views: 5440

[SOLVED] Cleanup problem of GroupBox

I created a custom GroupBox that has some extra AutoWindows (in addition to "__auto_contentpane__"). Everything works fine. However, during its cleanup these additional windows aren't removed. This is the corresponding entry in my looknfeel file: <WidgetLook name="BNBWidgets/Belt"...
by BrightBit
Sat Jun 02, 2012 15:20
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Label colour of pushed ToggleButton too dark
Replies: 7
Views: 2836

Re: Label colour of pushed ToggleButton too dark

You're welcome. I'm glad that I was able to help. It's the least I can do. I mean you already helped me by supplying your GUI library. :) BTW: By version attribute you mean the following line? <Imageset version="2" Name="TaharezLook" Imagefile="TaharezLook.tga" NativeHo...
by BrightBit
Fri Jun 01, 2012 11:46
Forum: Modifications / Integrations / Customisations
Topic: [SOLVED] Label colour of pushed ToggleButton too dark
Replies: 7
Views: 2836

Re: Label colour of pushed ToggleButton too dark

I modified/patched the TaharezLook.looknfeel, TaharezLook.scheme and Demo7Windows.layout to add a modified version of my toggle button: http://img850.imageshack.us/img850/314/togglebuttonlocation.png Here are the files: Modified Datafiles Just in case I wasn't precisely enough about my problem with ...

Go to advanced search