Search found 45 matches

by Boost113
Thu Oct 26, 2017 12:31
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Solved] Text and image texture corruption with Ogre 2.1 on Windows only
Replies: 6
Views: 1229

Re: [Bug?] Text and image texture corruption with Ogre 2.1 on Windows only

Poking around in the blending options I think I found where the issue is. There is this if statement in the Ogre Renderer.cpp on line 1121: if (d_pimpl->d_activeBlendMode == BlendMode::RttPremultiplied) Tweaking it I was able to completely break the text rendering: https://i.imgur.com/mZh37qR.png An...
by Boost113
Wed Oct 25, 2017 19:24
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Solved] Text and image texture corruption with Ogre 2.1 on Windows only
Replies: 6
Views: 1229

Re: [Bug?] Text and image texture corruption with Ogre 2.1 on Windows only

Actually, yeah it might be that the alpha blending is getting turned off and on causing the flickering and making the text appear as blocks. But that still leaves the incorrect colours of the textures. This is what it should look like: https://i.imgur.com/tBeSSVI.png (the top left GUI element is the...
by Boost113
Wed Oct 25, 2017 14:34
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Solved] Text and image texture corruption with Ogre 2.1 on Windows only
Replies: 6
Views: 1229

[Solved] Text and image texture corruption with Ogre 2.1 on Windows only

Hi, I'm randomly seeing all rendered text and sometimes GUI textures being corrupted. It looks like this: https://i.imgur.com/DrWrL9a.png This is what the texture corruption looks like: https://i.imgur.com/71MFL2k.png The correct rendering should look like this: https://i.imgur.com/7LS4szF.png I did...
by Boost113
Wed Oct 25, 2017 14:14
Forum: CEGUI Library Development Discussion
Topic: CEGUI on OGRE 2.1
Replies: 32
Views: 8741

Re: CEGUI on OGRE 2.1

I'm using the CEGUI default branch with Ogre 2.1 and it works great, at least on linux.
On Windows it may or may not work. I need to figure out whether I'm doing something wrong or if the glitching I'm sometimes seeing is actually a bug somewhere.
by Boost113
Mon Feb 16, 2015 15:16
Forum: Help
Topic: Ogre 2.0 + multiple windows = fail
Replies: 19
Views: 4476

Re: Ogre 2.0 + multiple windows = fail

Now I got the input working but there seems to be some flickering issues. What maybe happening is that Ogre isn't bothering to clear the screen every frame so the CEGUI junk shows up for a while until Ogre clears it. The flickering seems to only happen when something is moving/updating in CEGUI and...
by Boost113
Wed Feb 04, 2015 14:08
Forum: Help
Topic: Ogre 2.0 + multiple windows = fail
Replies: 19
Views: 4476

Re: Ogre 2.0 + multiple windows = fail

Now I got the input working but there seems to be some flickering issues. What maybe happening is that Ogre isn't bothering to clear the screen every frame so the CEGUI junk shows up for a while until Ogre clears it. The flickering seems to only happen when something is moving/updating in CEGUI and ...
by Boost113
Wed Feb 04, 2015 11:33
Forum: Help
Topic: Ogre 2.0 + multiple windows = fail
Replies: 19
Views: 4476

Re: Ogre 2.0 + multiple windows = fail

You don't seem to be using the Renderer bootstrap function. I'm not using bootstrap because it calls CEGUI::System::create inside. So if I call bootstrap once per program I get only 1 ogre renderer which's probably not the thing I want. If I call one bootstrap per window I get "Already Initial...
by Boost113
Tue Feb 03, 2015 19:10
Forum: Help
Topic: Ogre 2.0 + multiple windows = fail
Replies: 19
Views: 4476

Re: Ogre 2.0 + multiple windows = fail

Sorry for attributing your contributions to somebody else, Boost113. My memory is not the best ;) Well... I'm actually Henri Hyyryläinen ... so ... (It would probably avoid confusion if I hadn't used my "gaming" user name here) I just did a quick test and got this result, which seem corre...
by Boost113
Tue Feb 03, 2015 15:23
Forum: Help
Topic: Ogre 2.0 + multiple windows = fail
Replies: 19
Views: 4476

Re: Ogre 2.0 + multiple windows = fail

I did the CEGUI Ogre 2.0 renderer and here's a few things that might be useful: You don't seem to be using the Renderer bootstrap function. This call might be pointless and it could potentially break something: ceguiOgreRenderer->setDefaultRootRenderTarget(*window); You seem to be creating the works...
by Boost113
Mon Feb 02, 2015 17:38
Forum: Help
Topic: ComboBox resizing issue
Replies: 1
Views: 705

ComboBox resizing issue

Hi, I'm trying to create a ComboBox which should display all items when the drop down list is open. Though, it seems to only resize to fit a single element: http://i.imgur.com/apaaQ1n.png Even worse with the same .layout a ComboBox in a slightly different place doesn't resize at all: http://i.imgur....
by Boost113
Tue Jun 03, 2014 12:10
Forum: Help
Topic: Cannot set tab names with AutoWindows
Replies: 5
Views: 929

Re: Cannot set tab names with AutoWindows

Yeah, it would seem like there is some missing functionality when using only .layout files.
This might as well be a feature request for fixing the tab naming.
by Boost113
Tue Jun 03, 2014 12:04
Forum: Help
Topic: Cannot set tab names with AutoWindows
Replies: 5
Views: 929

Re: Cannot set tab names with AutoWindows

No, the problem is in both CEED (it crashes/throws an exception) and my application (not getting the names to display without using the workaround).
by Boost113
Tue Jun 03, 2014 09:58
Forum: Help
Topic: Cannot set tab names with AutoWindows
Replies: 5
Views: 929

Cannot set tab names with AutoWindows

I tried to create a window with a TabControl in CEED, it crashed. Then I looked at the samples and found out that they are using lots of C++ code to set up the tabs, not what I want. I tried many different things to set the names for the tabs but it seems that nothing works. What I think should work...
by Boost113
Mon Apr 21, 2014 06:57
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Request] Make the OgreRenderer work with the new Ogre 2.0
Replies: 62
Views: 12573

Re: [Request] Make the OgreRenderer work with the new Ogre 2

How is the rendering method different? IT should be the same if possible (for simplicity and for easier maintainement of docs and code), if you let me look at it we might find a way to accomplish this. As the rendering doesn't require the user to call any rendering methods it should say this somewh...

Go to advanced search