Search found 193 matches

by lucebac
Sun Aug 27, 2017 16:47
Forum: Help
Topic: undefined reference to glClear
Replies: 20
Views: 1859

Re: undefined reference to glClear

If you selected FreeImageImageCodec as the default ImageCodec during CMake configuration, then you have everything you need. Hit "Build", goto Code::Blocks, hit "build all" (or whatever the name is) and there you go. You will presumably have something like this then: ⋅ ...
by lucebac
Sun Aug 27, 2017 09:03
Forum: Help
Topic: undefined reference to glClear
Replies: 20
Views: 1859

Re: undefined reference to glClear

From the list of linked libraries in your first post I call tell that you are missig any libCEGUI*ImageCodec.dll. Therefore it crashes. Please add the default image codec DLL to your application directory. You can see which one to use in CMake.
by lucebac
Fri Aug 25, 2017 14:21
Forum: Help
Topic: undefined reference to glClear
Replies: 20
Views: 1859

Re: undefined reference to glClear

Yes, you are right - OpenGL is a specification. But all graphics cards implement it and almost any operating system ships with the respective driver (suite) to use OpenGL for graphics rendering. The GCC compiler shipped with CodeBlocks should have a opengl32.dll.a somewhere around and you just have ...
by lucebac
Fri Aug 25, 2017 13:53
Forum: Help
Topic: undefined reference to glClear
Replies: 20
Views: 1859

Re: undefined reference to glClear

yes, because it's an "optional" dependency if you decide to use OpenGLRenderer. And if you had looked into my application template, you would have noticed that I wrote down opengl as a dependency for that.
by lucebac
Fri Aug 25, 2017 10:09
Forum: Help
Topic: undefined reference to glClear
Replies: 20
Views: 1859

Re: undefined reference to glClear

You have to link opengl32.a
by lucebac
Thu Jul 13, 2017 18:36
Forum: Help
Topic: CEGUI 0.8.7 and SFML 2.4.2 - load imageset
Replies: 3
Views: 750

Re: CEGUI 0.8.7 and SFML 2.4.2 - load imageset

Usually, this is because your datafiles folder is not where CEGUI expects it. If you use Visual Studio and just clicked "debug" or "run", the working directory is set "wrong". You can either set the Debug directory of VS to "$(OutDir)" or launch the executable...
by lucebac
Tue Jul 04, 2017 18:11
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

The statement fails because you use ExpatParser instead of XercesParser, like I do. Expat does not support schema validation, so this is expected behaviour. But the really interesting thing is another thing: you said that you just copied over my libraries to your project and it works. This definitel...
by lucebac
Mon Jul 03, 2017 01:12
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

Can you paste your CEGUI CMakeCache.txt file?
by lucebac
Fri Jun 30, 2017 16:27
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

As you did not reply to my PM, I'd like to notify you of my message ;)
by lucebac
Tue Jun 27, 2017 22:03
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

Sorry, my answer a bit misleading. You create your m_context by using CEGUI::OpenGL3Renderer::bootstrapSystem. I create the context by initializing both the renderer and the System object by hand (see first lines of initCEGUI in my SDL2 template). Your code should then look like using namespace CEGU...
by lucebac
Tue Jun 27, 2017 08:16
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

The m_context nullptr access violation can be because of the way you create the context. Please compare your way of creating the context to the way I do in the SDL2 application template.
by lucebac
Mon Jun 26, 2017 22:24
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

While reviewing your code, I found something that might cause problems: You are creating the root window out of nowhere - you did not load both the default scheme and default font between initializing CEGUI and creating the root window. I'd recommend to change the code of cGUI::init according to thi...
by lucebac
Sun Jun 25, 2017 23:03
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

If you want, you can zip up the whole thing and I can have a look into it later. Maybe I (or someone else) can find the issue that way.
by lucebac
Sun Jun 25, 2017 09:51
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

Ok, I don't see any odd things in the logs. To be honest, I don't know what the cause of your problem is. But I can give you a few hints where you could check for difficulites: ⋅ mixing debug and non-debug code ⋅ mixing 32 and 64 bit code ⋅ your initialization of CEGUI:...
by lucebac
Sat Jun 24, 2017 12:14
Forum: Help
Topic: injectMousePosition returning nullptr
Replies: 23
Views: 2284

Re: injectMousePosition returning nullptr

Hi PackedCrack, as Ident told you, he wrote a message to the guy who wrote the SDL2 template. And there I am ;) I tried to reproduce your problem by doing everything like you did but unfortunately, it worked like a charm for me. Can you paste your CEGUI.log file here? It seems like the initializatio...

Go to advanced search