Search found 9 matches

by Teenee
Tue Sep 19, 2017 14:21
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

CEGUI is actually drawing the black rectangle, if I have my Texture Target have a declared render size of 1920 x 1080, this will show up: https://gyazo.com/fae8d9f51a637fe112145402c60a9879 But if I set it to 500x500, the rectangle becomes smaller: https://gyazo.com/dedfe2c7ae7a4a5bd240914a7fa9db2f T...
by Teenee
Mon Sep 18, 2017 20:04
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Seems setting these values was easier than I thought, I am just blind that is all... SFML supports context settings where you can set the depth and stencil buffers and the anti aliasing level. Right now my OpenGL states are practically identical, apart from: GL_COLOR_CLEAR_VALUE={0, 0, 0, 0} > GL_CO...
by Teenee
Mon Sep 18, 2017 18:15
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Yes, I forgot to mention but I have compared them and tried to reset GL_SAMPLE_BUFFERS, GL_SAMPLES, GL_STENCIL_BITS and GL_DEPTH_BITS, but I do not really know how. I have looked at the CEGUI examples and they seem to run with both GL_SAMPLE_BUFFERS and GL_SAMPLES at 0. GL_STENCIL_BITS and GL_DEPTH_...
by Teenee
Mon Sep 18, 2017 16:46
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

So I have tried out geDEBugger and I got some state changes, although they don't mean much to me and I have a hard time resetting them to their initial states. Maybe you can help me out with this, or know what states are important to be set for CEGUI. I have set 2 breakpoints, one after window creat...
by Teenee
Sun Sep 17, 2017 19:35
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

I will give it a try. You said gldebugger, I assume you meant gDEBugger, since that is the only thing I can find online. I'll come back with info if I find something :)
by Teenee
Sun Sep 17, 2017 19:00
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

hmm, well I did disable multithreading and it didn't help. So that is probably not the problem. However, I am also curious why m_Renderer->getDefaultRenderTarget( ) would not work aswell as a RenderTarget. I assume it's the same reason as why the TextureTarget does not work?
by Teenee
Sun Sep 17, 2017 18:24
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Disabled all OpenGL functions, disabled multithreading and disabled all inputs, still got the same black rectangle on screen.
by Teenee
Sun Sep 17, 2017 18:01
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

Re: CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

I have tried my best to remove all OpenGL functions when I posted this. The OpenGL calls DrawGUI and m_Window->display() only call the GUI draw given above and draw the window through SFML. Without these I would not have anything on the screen. I might have missed some OpenGL functions, the project ...
by Teenee
Sun Sep 17, 2017 15:35
Forum: Help
Topic: [Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box
Replies: 21
Views: 2145

[Solved] CEGUI 0.8.7 and OpenGL 4.5.0 - GUI only draws a black box

Hello, I have been working on getting CEGUI working the past couple of days, and it seems it is not going that well. I do not get any errors, but I do get a black box instead (I am quite a noob in graphics programming btw :? ) I use CEGUI 0.8.7, OpenGL 4.5.0 and SFML 2.3.2. I work on Windows 10 64-b...

Go to advanced search