Search found 26 matches

by nfz
Mon Jun 20, 2005 15:59
Forum: Modifications / Integrations / Customisations
Topic: No tutorials/learning tools?
Replies: 3
Views: 606

Re: No tutorials/learning tools?

I know a lot of people don't like this method but I went through the demos (1 to 7) and read through the headers and the source and found this helped a lot in getting started.
by nfz
Sat Feb 26, 2005 05:38
Forum: Modifications / Integrations / Customisations
Topic: Crash at the scheme loading
Replies: 21
Views: 5156

Re: Crash at the scheme loading

CE, you are not alone. I built the Ogre VC7.1 SDK using Ogre CVS v1-0-0 and CEGUI 0.2.0 src and found no problems running Demo_GUI in debug. I didn't use the pre-built Xerces so maybe that has something to do with it. Had me worried when I saw this post just after the SDK were released so I download...
by nfz
Fri Feb 11, 2005 19:21
Forum: Modifications / Integrations / Customisations
Topic: rendering problems with ogre and cegui
Replies: 13
Views: 2900

Re: rendering problems with ogre and cegui

Well, never got a reply from ATI about this problem but Catalyst 5.2 is out and the problem is now gone. Ogre GL renderer now works fine with CEGUI.
by nfz
Wed Feb 09, 2005 14:29
Forum: Bug Reports, Suggestions, Feature Requests
Topic: CEGUIPrequisites ??
Replies: 5
Views: 1870

Re: CEGUIPrequisites ??

:oops: ...crawls back into hole..
by nfz
Tue Feb 08, 2005 21:26
Forum: Bug Reports, Suggestions, Feature Requests
Topic: CEGUIPrequisites ??
Replies: 5
Views: 1870

Re: CEGUIPrequisites ??

I think for most people this could be handy. I have done up a basic one for my needs but having a generic one done up by the master would be useful :).
by nfz
Fri Jan 28, 2005 05:09
Forum: Modifications / Integrations / Customisations
Topic: rendering problems with ogre and cegui
Replies: 13
Views: 2900

Re: rendering problems with ogre and cegui

Made some headway on this. Its not Dynamic vbo and alpha blending as I thought since my little test app works fine. Seems to be something in the render state setting in gl when an Ogre material gets rendered then CEGUI. Kind of a deja vu with the SO_FLAT/SO_GOURAUD problem. Seems like the previous d...
by nfz
Fri Jan 28, 2005 04:33
Forum: Modifications / Integrations / Customisations
Topic: rendering problems with ogre and cegui
Replies: 13
Views: 2900

Re: rendering problems with ogre and cegui

When I tried out the new catalyst drivers (5.1) on 17 Jan 05 I ran into the same problem. I rolled back to 4.12 for now untill I get a response back from ATI dev support or the next driver comes out. My bet is the next driver update will be out before I get a response to my query about the problem. ...
by nfz
Fri Jan 21, 2005 01:00
Forum: CEGUI Library Development Discussion
Topic: Ogre Renderer missing setShadingType()
Replies: 1
Views: 1040

Ogre Renderer missing setShadingType()

OgreRenderer::initRenderStates() is missing: d_render_sys->setShadingType(SO_GOURAUD); Without it the shadingType will be what ever material was used just before CEGUI renders. I found this out when using some materials that used SO_FLAT. I wasn't getting the proper vertex colour shading wit...
by nfz
Fri Dec 17, 2004 20:24
Forum: Offtopic Discussion
Topic: CEGUI Logo
Replies: 7
Views: 3691

CEGUI Logo

I ussumed the gif at the top of this page was official so I have been using that.
by nfz
Thu Dec 16, 2004 07:24
Forum: CEGUI Library Development Discussion
Topic: OgreResourceProvider memory leak
Replies: 6
Views: 2125

OgreResourceProvider memory leak

Ok, here is what I am using as a second solution: I got rid of the typedef for InputSourceContainer and made it a subclass of DataContainer. Here is the class: class InputSourceContainer : public DataContainer<XERCES_CPP_NAMESPACE::InputSource> { public: InputSourceContainer(&...
by nfz
Thu Dec 16, 2004 05:16
Forum: CEGUI Library Development Discussion
Topic: OgreResourceProvider memory leak
Replies: 6
Views: 2125

OgreResourceProvider memory leak

That was my first solution but it causes a bigger problem. Basically its a conflict between Ogre memory manager and Xerces memory manager and causes a crash inside Xerces when it tries to delete the buffer created by Ogre::DataChunk. My current working solution is a little ugly and involves keeping ...
by nfz
Thu Dec 16, 2004 00:40
Forum: CEGUI Library Development Discussion
Topic: OgreResourceProvider memory leak
Replies: 6
Views: 2125

OgreResourceProvider memory leak

I've spotted a memory leak while using OgreResourceProvider. I know _Mental_ had hinted at some leaks about a week and a half ago but then mentioned that they were corrected. I've waited since the 9 Dec to see if the fixes would come through on anonymous cvs but still nothing yet. I'll give a quick ...
by nfz
Tue Dec 14, 2004 19:53
Forum: Modifications / Integrations / Customisations
Topic: new Event parameters
Replies: 3
Views: 689

new Event parameters

I know I am not CE but I'll make a stab at this since I started you on the change and I suspected this would cause a headache for you. Event::Subscriber template does not support user definable number of arguments like boost::bind does. I think you have two alternatives. The first one is to change y...
by nfz
Tue Dec 14, 2004 04:11
Forum: Modifications / Integrations / Customisations
Topic: combo box weirdness
Replies: 7
Views: 957

combo box weirdness

Forgot to mention that the vertical size of the Combobox effects the vertical size of the droplist too which is probably your problem and not clipping (yet). The vertical size of the combobox effects both the vertical size of the editbox and the combobox. Think of the vertical size of the combobox a...
by nfz
Tue Dec 14, 2004 03:44
Forum: Modifications / Integrations / Customisations
Topic: combo box weirdness
Replies: 7
Views: 957

combo box weirdness

If its the child list box being clipped (most probable) then there are a few solutions. The easiest fix I found so far is the following code snippet: CEGUI::Window* droplist = mComboboxWidget->getChild(mComboboxWidget->getName() + "__auto_droplist__");...

Go to advanced search