Search found 71 matches

by mmixLinus
Tue Jan 28, 2014 18:51
Forum: Help
Topic: [SOLVED] Runtime crash with cegui 0.8.2 with ogre
Replies: 20
Views: 4973

Re: Runtime crash with cegui 0.8.2 with ogre

some progress then :)
np, see you later!
by mmixLinus
Mon Jan 27, 2014 12:01
Forum: Help
Topic: [SOLVED] Runtime crash with cegui 0.8.2 with ogre
Replies: 20
Views: 4973

Re: Runtime crash with cegui 0.8.2 with ogre

Please see this regarding %llu. Could be relevant for your setup. Have you tried printing your uint64 values after the sscanf? Do they look right? I still think you have a String mixup of sorts (maybe compiling different parts of your project with different basic string types). Or maybe simply using...
by mmixLinus
Fri Jan 24, 2014 14:31
Forum: Help
Topic: [SOLVED] Runtime crash with cegui 0.8.2 with ogre
Replies: 20
Views: 4973

Re: Runtime crash with cegui 0.8.2 with ogre

Why has it started to print

Code: Select all

There is no Property named 'Ā
? Looks like a property (in a layout file?) with wrong character encoding? See mojibake. Shouldn't crash due to this though.
by mmixLinus
Wed Jan 08, 2014 09:53
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Solved/NoBug] Shift key states don't lose focus
Replies: 11
Views: 3919

Re: [Bug?] Shift key states don't lose focus

Sounds right to me.
@slack41, if your main window loses focus you need to inject fake release key/button messages.

A classic (for me at least) was Alt-Tab in Windows. When the window regains focus Alt has been "down" all the time, and stays down until I press/release Alt again.

/mmixLinus
by mmixLinus
Mon Dec 02, 2013 09:34
Forum: CEGUI Library Development Discussion
Topic: Modularized Boost
Replies: 1
Views: 3798

Modularized Boost

Hi,
Found this regarding Boost project setup, but no actual source. I suppose this will have an impact. See github.
/mmixLinus
by mmixLinus
Mon Nov 18, 2013 14:40
Forum: Help
Topic: It's too slow because using layout to create window
Replies: 4
Views: 2561

Re: It's too slow because using layout to create window

Hi silentyears I have the same "problem", but it is probably mostly due to a design choice I made early in my project . It loads the layouts, and creates quite a few windows, most of which I don't actually need right at startup.. :oops: Eventually, I will solve this by creating the windows...
by mmixLinus
Wed Nov 13, 2013 08:28
Forum: Help
Topic: Multiple render roots
Replies: 13
Views: 2870

Re: Multiple render roots

Sorry, I can't help you, but PLEASE post your solution once you find it!
Maybe this, this or this can help.

Thanks!
/mmixLinus
by mmixLinus
Tue Nov 12, 2013 13:44
Forum: Help
Topic: CEGUI Started : OpenGLRenderer
Replies: 2
Views: 918

Re: CEGUI Started : OpenGLRenderer

Yeah, go ahead and post some log output (setLogFilename). Maybe search in Windows for it?
/mmixLinus
by mmixLinus
Wed Sep 25, 2013 21:29
Forum: Help
Topic: Cannot execute lua function from the ui event
Replies: 2
Views: 970

Re: Cannot execute lua function from the ui event

Don't know. Because you had the <Event ...> in Button3, but did subscribeEvent() on Button2? Sorry, just joking :lol: Let us know if you figure it out, and please set the original message's Subject to "[Solved] Cannot..." when you're done.
by mmixLinus
Wed Sep 25, 2013 21:22
Forum: Help
Topic: Why does the window cover the cursor?
Replies: 6
Views: 1406

Re: Why does the window cover the cursor?

Hi silentyears!

Difficult to say why you are seeing this problem. Could you post some code:

Code: Select all

code
and let us know your CEGUI version! And of course, post the beginning of your CEGUI.log - thanks! 8)
by mmixLinus
Sat Sep 21, 2013 09:37
Forum: Bug Reports, Suggestions, Feature Requests
Topic: [Change] Performance problem: MCL::setItem() is O(n^2)
Replies: 4
Views: 4219

Re: [Change] Performance problem: MCL::setItem() is O(n^2)

Hi team, Well, if you define soon as being "within one month" then it seems I made it! (Not forgetting the obligatory multiplication with pi squared). :lol: So, what I'm trying to say, is that I got around to experimenting with deferring MultiColumnList updates , useful when you're buildin...
by mmixLinus
Fri Sep 20, 2013 21:16
Forum: Help
Topic: [Open] Beginners - Having problems with Setting up SDK
Replies: 16
Views: 8793

Re: Beginner Kick Start - Having problems with Setting up SD

Funny side note (regarding your initial post).. As described here, Visual Studio 2012 is version 11.0...
Confused? Me too :lol: /mmixLinus
by mmixLinus
Wed Sep 18, 2013 15:22
Forum: Help
Topic: [Solved] Editbox has invisible selection :(
Replies: 1
Views: 698

Re: Editbox has invisible selection :(

Ok, rather simple solution. It seems that Activated-by-MouseClick prevents me from selecting the editbox text inside the ActivatedEvent handler. If I also subscribe to MouseClick, it's obvious that these two events go together when clicking in an Editbox. So my solution was to select the text in the...
by mmixLinus
Fri Sep 13, 2013 21:22
Forum: Help
Topic: [Solved] Editbox has invisible selection :(
Replies: 1
Views: 698

[Solved] Editbox has invisible selection :(

Hi, Static Debug build 0.7.4, win32 13/09/2013 23:01:38 (Std) +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 13/09/2013 23:01:38 (Std) + Crazy Eddie's GUI System - Event log + 13/09/2013 23:01:38 (Std) + (http://www.cegui.org.uk/) + 13/09/2013 23:01:38 (Std) +-+-+-+-...

Go to advanced search