Search found 37 matches

by pav
Tue Dec 13, 2011 12:47
Forum: Bug Reports, Suggestions, Feature Requests
Topic: Auto-cast boolean properties when used in DimOperators
Replies: 2
Views: 604

Re: Auto-cast boolean properties when used in DimOperators

CrazyEddie wrote:please add the request to the mantis tracker


Done, thank you.
by pav
Mon Dec 12, 2011 16:03
Forum: Help
Topic: DimOperator: (A*B) + (C*D) + E
Replies: 0
Views: 604

DimOperator: (A*B) + (C*D) + E

Is this possible? The best I could come up with is the following but (A*B) is ignored. Note: using AbsoluteDim for simplicity <AbsoluteDim value="E"> <DimOperator op="Add"> <AbsoluteDim value="A"> <DimOperator op="Multiply"> <AbsoluteDim value="B"/> ...
by pav
Mon Dec 12, 2011 10:17
Forum: Bug Reports, Suggestions, Feature Requests
Topic: Auto-cast boolean properties when used in DimOperators
Replies: 2
Views: 604

Auto-cast boolean properties when used in DimOperators

As the title says, it'd be nice if boolean properties could be cast to floats (0 / 1) when used inside/with a DimOperator. Forgive me if my request happens to be invalid; the project is pretty big and I might have missed something. This would help when creating WidgetLooks that have children that ca...
by pav
Sun Dec 11, 2011 03:32
Forum: Help
Topic: Animating all states of a push button via XML
Replies: 1
Views: 309

Animating all states of a push button via XML

I have a push button widget with a property named "CurrentBackgroundColours" that is used on the "Normal" StateImagery (which is the only one defined). I'm trying to have 4 or 5 different ColourRect PropertyDefinitions (one for each state, possibly including the Pushed-Off state)...
by pav
Sat Dec 10, 2011 14:32
Forum: Help
Topic: Ogre 1.8 not recognize during Cegui build configuration
Replies: 1
Views: 639

Re: Ogre 1.8 not recognize during Cegui build configuration

What's the output of

Code: Select all

pkg-config --modversion OGRE

Does it find OGRE? On my system it says: "1.8.0unstable"
by pav
Sat Dec 10, 2011 12:25
Forum: Help
Topic: [solved] Falagard: Properties and animating colour
Replies: 2
Views: 360

Re: Falagard: Properties and animating colour

Ah, of course. Thanks a lot! It works fine now, but even though I have replayMode="once", it loops and doesn't stop... I'll look into it some more and post a new thread if I can't figure it out.

Solved. :D
by pav
Fri Dec 09, 2011 15:30
Forum: Help
Topic: [solved] Falagard: Properties and animating colour
Replies: 2
Views: 360

[solved] Falagard: Properties and animating colour

Hello, I've started working with CEGUI and I love it so far; it's amazingly powerful, although a bit hard to learn. I'm having some problems animating colors. I started simple with a push button, like this: ... <PropertyDefinition name="NormalBackgroundColours" initialValue="tl:FFEEEE...

Go to advanced search