Search found 1105 matches

by scriptkid
Fri Jan 01, 2010 16:17
Forum: Unofficial CEGUI-Related Tools
Topic: CEGUIEditor for version 0.7.1 - when?
Replies: 12
Views: 3633

Re: CEGUIEditor for version 0.7.1 - when?

Okay, a pretty much stable version of the editor for 0.7.1 is available as of now: http://sourceforge.net/projects/crayzedsgui/files/CELayoutEditor/0.7.1/CELayoutEditor%200.7.1a.zip/download (btw a new 0.6 installer is available as well, which is a bug-fix release. These fixed are also applied to 0....
by scriptkid
Thu Dec 31, 2009 11:17
Forum: User Projects
Topic: Snakeworlds (snake game) UPDATE: netbook support!
Replies: 14
Views: 7974

Re: Snakeworlds (3D snake game) *released* at 4/3/09!

Hi all, This is an update about my own snake game. As of this month, it is optimized to run on netbooks / mini-laptops. When the game detects this, it will fall back to a low-end mode, to keep the game running with a safe fps. For the Cegui part it means that i have re-created most screens, because ...
by scriptkid
Tue Dec 29, 2009 14:23
Forum: Unofficial CEGUI-Related Tools
Topic: [CELayoutEditor] assert if click on static text with a %
Replies: 2
Views: 3166

Re: [CELayoutEditor] assert if click on static text with a %

This has been fixed, and will be available in a new release.
by scriptkid
Tue Dec 29, 2009 10:38
Forum: Unofficial CEGUI-Related Tools
Topic: Apparent bug in CELayoutEditor 0.6.3b, Image attribute
Replies: 3
Views: 2028

Re: Apparent bug in CELayoutEditor 0.6.3b, Image attribute

EDIT: It seems every time I was pressing enter. If you just click it seems to work. I need to try it with a clean install of 0.6.3b but it seems pressing enter is definitely the problem. Okay thanks for mentioning about the Enter key. That's surely the reason then. I have already fixed it locally, ...
by scriptkid
Sun Dec 27, 2009 11:51
Forum: Help
Topic: How to create two windows by tow layout file?
Replies: 2
Views: 387

Re: How to create two windows by tow layout file?

Hi and welcome, It's a bit little info, but the most obvious reason would be that both layouts define some sort of fullscreen 'root' window, in which case the second one's (invisible) root will 'eat' all input ot the underlaying layout. If that's not the case, please post both layouts here as a code...
by scriptkid
Sun Dec 27, 2009 10:59
Forum: Unofficial CEGUI-Related Tools
Topic: I cannot change the name in the property
Replies: 5
Views: 2615

Re: I cannot change the name in the property

jonmiller wrote:Thanks for looking into this. Also I noticed that I wasn't able to manually update the absolute and relative positions. So it seems that any of the options listed in green text are not able to be modified manually.

Thanks


I was not able to reproduce this, neither with Enter or Clicking. Sorry ;)
by scriptkid
Sun Dec 27, 2009 10:55
Forum: Unofficial CEGUI-Related Tools
Topic: I cannot change the name in the property
Replies: 5
Views: 2615

Re: I cannot change the name in the property

Okay i can confirm this too. Apparently, for String fields, submitting a value using Enter doesn't seem to work. If you click the mouse on a different row, thus NOT clicking Enter, it does submit... I'm onto it.
by scriptkid
Sun Dec 27, 2009 10:47
Forum: Unofficial CEGUI-Related Tools
Topic: Apparent bug in CELayoutEditor 0.6.3b, Image attribute
Replies: 3
Views: 2028

Re: Apparent bug in CELayoutEditor 0.6.3b, Image attribute

[EDIT] This might also have todo with this bug: http://www.cegui.org.uk/phpBB2/viewtopic.php?f=7&t=4521 Did you use Enter to submit the value or clicking the mouse on a different row? [EDIT] Hi and welcome :) I downloaded the 0.6.3b version myself and tried the same, but on my end it worked. Do ...
by scriptkid
Tue Dec 22, 2009 10:31
Forum: Modifications / Integrations / Customisations
Topic: Add pictures and words
Replies: 5
Views: 1244

Re: Add pictures and words

Indeed, like this one: http://www.cegui.org.uk/wiki/index.php/ ... istboxItem

Just replace 'checkbox' with 'image' ;)
by scriptkid
Thu Dec 17, 2009 10:58
Forum: Help
Topic: How to clone/copy windows
Replies: 3
Views: 1026

Re: How to clone/copy windows

Hi, Such a basic thing is not possible out of the box ;) You'd need a copy method which copies all your properties and such. Something like this: //------------------------------------------------------------------------ Window* CopyWindow( const CEGUI::Window* pSource ) { // create window of same t...
by scriptkid
Mon Dec 14, 2009 15:42
Forum: Help
Topic: Drag and drop-box, How do I do it?
Replies: 16
Views: 1484

Re: Drag and drop-box, How do I do it?

Hi, I don't see the MousePassThroughEnabled property in the files which you post. Maybe the editor didn't save them? I am looking in that direction. From the editor point of view, i see what's going on. The INI file doesn't have the property in its "SupportedProperties" option. So i don't ...
by scriptkid
Sun Dec 13, 2009 15:44
Forum: Help
Topic: CEGUI D3DX10, release missing CEGUIBase_d.dll?
Replies: 8
Views: 2118

Re: CEGUI D3DX10, release missing CEGUIBase_d.dll?

This is odd, when i open the SDK projects for 0.7.1 i see correct settings:

Image

Am i looking at the wrong settings?
by scriptkid
Thu Dec 10, 2009 08:36
Forum: Help
Topic: Static
Replies: 2
Views: 329

Re: Static

Hi, Assuming that you will be using 0.7, you can download the SDK (windows) or the sources (linux/mac) via this page: http://www.cegui.org.uk/wiki/index.php/CEGUI_Downloads_0.7.1 The MS VC dependencies also have statically linked versions in them. In your own project, you must define CEGUI_STATIC in...
by scriptkid
Tue Dec 01, 2009 10:08
Forum: Help
Topic: Problem Compiling CEGUI Under VC10
Replies: 8
Views: 3144

Re: Problem Compiling CEGUI Under VC10

Hi,

Thanks for sharing this! It seems that they have made things much even more tight this round.
by scriptkid
Tue Dec 01, 2009 09:25
Forum: Help
Topic: Problem with Ogre and CEGUI new system
Replies: 9
Views: 725

Re: Problem with Ogre and CEGUI new system

Hi,

Please look at your cegui.log file, it should at least give you a hint of what's going on! Also, look at this post for example:
viewtopic.php?f=10&t=4445&p=20763&hilit=bootstrap#p20763

You are probably missing an xml loader or something.

Go to advanced search