Page 1 of 1

Exception: DefaultResourceProvider

Posted: Mon Aug 07, 2006 10:37
by angela4et
em in my log file i keep getting this exception

pls anyone knows how to resovle this ?


07/08/2006 18:30:08 (Error) Exception: DefaultResourceProvider::load - Imageset.xsd does not exist
07/08/2006 18:30:08 (Error) Exception: DefaultResourceProvider::load - Font.xsd does not exist


Posted: Mon Aug 07, 2006 10:59
by scriptkid

when cegui loads an xml file, it looks for the corresponding xsd file to validate that xml file. Try to copy the xsd files from "datafiles/<resource>/resource.xsd" into your applications' startup folder. To avoid more errors, please copy these as well:


Good luck! :-)

Posted: Tue Aug 15, 2006 06:10
by angela4et
thanks it works!
but i notice i can only put it in the same derectory with the debug.exe
other than that it just give me the same error.
how can i solve that also?
i mean just dump everything there looks very messy..... :idea: :)

Posted: Wed Aug 16, 2006 11:13
by CrazyEddie
Assuming version 0.4.1.

It *should* function with the .xsd files in either the startup directory or the same directory as the XML file being loaded. However, in the latter case you will still get an error logged (once it fails the first time, it will look in the alternate location). Fatality only occurrs when you get the two errors.

For info, in 0.5.0 code DefaultResourceProvider has been improved, and it's possible to have the Xerces XML parser look in an arbitary location for the .xsd files. Having said this, of course you probably want to wait for 0.5.0 stable release before evaluating and deciding whether to upgrade - especially since there are quite some breaking changes in there for existing projects.

If you are already using the 0.5.0 Release Candidates, then please look at the following: