CEGUI 0.5 ?

Forum for general chit-chat or off-topic discussion.

Moderators: CEGUI MVP, CEGUI Team

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

CEGUI 0.5 ?

Postby Pompei2 » Tue Oct 24, 2006 13:12

Hello,

I know that programmers don't like to say dates and won't like my question :), but can you tell us approximately when you plan to make the final release of 0.5 ?
I looked at the roadmap and saw that every task is marked as complete so I think it will be soon ?

peace

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Tue Oct 24, 2006 13:54

Aside from another bug-fix or two, it will be released as soon as the build updates for Mac OS X are completed.

CE.

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

Postby Pompei2 » Tue Oct 24, 2006 15:43

ok that's cool thank you :)

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Mon Nov 27, 2006 17:28

Stable release 0.5.0 is not stable and was I unable to build from src due to missing headers and cpp's in DirectX9 render modules.

User avatar
lindquist
CEGUI Team (Retired)
Posts: 770
Joined: Mon Jan 24, 2005 21:20
Location: Copenhagen, Denmark

Postby lindquist » Mon Nov 27, 2006 20:52

the dx9 renderer has been tested. we dont provide the dx9 sdk. sure you're not just missing this?

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Tue Nov 28, 2006 00:19

The reason I was trying to build from source is because I need to use the Aug 06 dx sdk (version installed in uni) and the latest sdk (oct?) is used in the downloadable compiled gui sdk.
There are no files in the dx renderer solution and they are not in the directory either.

User avatar
lindquist
CEGUI Team (Retired)
Posts: 770
Joined: Mon Jan 24, 2005 21:20
Location: Copenhagen, Denmark

Postby lindquist » Tue Nov 28, 2006 01:59

you will need to grab the source to recompile. or svn if you want the bleeding edge. recompiling is not hard with the dependency packages available. it should be fairly much out of the box!

you may have to tweak the config.lua script is makesfiles/premake

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Tue Nov 28, 2006 02:32

Ok it seems we are going in circles here:)
I dled the "stable" source and it does not seem to have all the required files, thus it seems not to be a stable release.

User avatar
lindquist
CEGUI Team (Retired)
Posts: 770
Joined: Mon Jan 24, 2005 21:20
Location: Copenhagen, Denmark

Postby lindquist » Tue Nov 28, 2006 03:07

ok.. could you tell us which files are missing?

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Tue Nov 28, 2006 03:35

Sorry I'm on another machine now and dont have the correct info, but the samples were giving errors that it could not find the dx9 renderer files in render modules directory, from looking at the other release candidates it seems there may also be dx9 texture files missing(unless these have been added to the project since). When I built the project it built without errors but did not generate a dx9 renderer dll, I assume this is because there are no files in the dx9renderer solution.

User avatar
lindquist
CEGUI Team (Retired)
Posts: 770
Joined: Mon Jan 24, 2005 21:20
Location: Copenhagen, Denmark

Postby lindquist » Tue Nov 28, 2006 06:29

OK. I had a look at the source zip for 0.5.0. and it does seem eddie messed something up. the files are indeed missing. only the GL and Irrlicht renderers are there :/

I think the problem is that he used a script and made the files in linux from the makefiles. the linux makefiles do not reference the dx stuff at all.

I will make a new source zip for windows when I have time, but it probably wont be before the weekend. until then you will have to use the version in svn.

sorry for this inconvenience, and that I didn't check right away, I really thought this had been checked :/

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Tue Nov 28, 2006 09:41

Yeah, Lindquist is right; the packages were automatically generated - I missed the fact the D3D renderers were not included. I had previously gone through and added a load of other missing stuff, but these still slipped through the net.

So, that's a bit of a disaster :oops: Since this is a major balls up on my part, and that Lindquist is busy until the weekend, I'll fix the missing references (to save future repeats of the same issue), and regenerate and upload a set of new packages later today.

Seems we'll be having 'b' series source packages to go with our 'b' series binary packages after all. I'll post back here when it's done.

Sorry again for dropping the ball on this one.

CE.

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Tue Nov 28, 2006 10:50

Ok at least it will now be sorted. I cant believe nobody has tried to build it from source or maybe they have and just gave up:(
Thanks for correcting it.

[edit ]
While Im talking about it, could you also please explain why you use the latest version of dx yet are using lua 50. In my project Im using lua 511, do you think this will cause me any problems or will i just have to have both as dependencies?

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Tue Nov 28, 2006 11:33

Ok, the new packages are now available. I tested using VC++ 7.1, and everything seems to be available (i.e. no missing files!).

The thing with using the latest DX9 sdk, but not the latest Lua is basically due to the fact that the system will build with any DX9 SDK version without modification (that is, they are all source compatible with each other) - so there's no issue for us to be using the latest. However, to build with Lua 5.1, modifications to the code are required, so this is not officially supported at the moment.

As I understand it, the two Lua versions are separate entities (you would end up with a context for each version), so you will likely see issues there I think. I believe there is a thread here on the forum somewhere which details what must be done to update CEGUI to use Lua 5.1.

CE.

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Thu Nov 30, 2006 13:32

CrazyEddie wrote: I believe there is a thread here on the forum somewhere which details what must be done to update CEGUI to use Lua 5.1.

CE.


I have had a search for this post, but so far have been unable to find it. Can anybody give a link to it?
Cheers.


Return to “Offtopic Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests