help! about DEMO for dx9...

Forum for general chit-chat or off-topic discussion.

Moderators: CEGUI MVP, CEGUI Team

User avatar
yizhong
Just popping in
Just popping in
Posts: 14
Joined: Wed Jan 12, 2005 12:06

help! about DEMO for dx9...

Postby yizhong » Wed Oct 27, 2004 08:01

:cry:
help-_-, where can i get the DEMO write for dx9 using cegui?

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

help! about DEMO for dx9...

Postby CrazyEddie » Wed Oct 27, 2004 09:21

Yeah, the "official" samples have been delayed, and delayed. Sorry about this.

What I'll do is port a couple of the Ogre demos over to use DirectX 9. You'll have to give me a day or two though :)

CE.

User avatar
yizhong
Just popping in
Just popping in
Posts: 14
Joined: Wed Jan 12, 2005 12:06

help! about DEMO for dx9...

Postby yizhong » Thu Oct 28, 2004 02:55

thanks!
today i try the cegui with the dx9 d3d sample 'billboard', it shown cool!!! :lol:

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

help! about DEMO for dx9...

Postby CrazyEddie » Thu Oct 28, 2004 12:07

I have re-written Demo7 to use the Direct3D9 renderer. It can be downloaded [color=0000AA]From Here[/color]

Much of the code is ripped from the samples framework which I have half finished, so if some of the code is a little strange, this is the reason why :)

The only project file supplied is for VC7.1, though it's easy to create a project for whatever compiler you're using. The dlls in the Release directory were compiled against my local cegui_mk2 which has some un-committed modifications, so if you re-compile you should replace those dlls with your own versions.

CE.

User avatar
yizhong
Just popping in
Just popping in
Posts: 14
Joined: Wed Jan 12, 2005 12:06

help! about DEMO for dx9...

Postby yizhong » Fri Oct 29, 2004 06:34

I have re-complie the code for d3d9 'demo7'.

before re-complie, the release work well, but after i can't see any thing but the fps, why?

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

help! about DEMO for dx9...

Postby CrazyEddie » Fri Oct 29, 2004 08:34

Sounds like a error loading one of the files. Check the CEGUI.log file and see what it says.

If you're running from within Visual C++ IDE, you'll need to set the working directorty for debugging - for VC7.0 or VC7.1 set it to $(TargetDir), for VC6 you'll need to set the path by hand.

HTH

CE.

User avatar
yizhong
Just popping in
Just popping in
Posts: 14
Joined: Wed Jan 12, 2005 12:06

help! about DEMO for dx9...

Postby yizhong » Mon Nov 01, 2004 03:52

after i download the newest cegui and recomplie the dll, now i can run the 'demo7' well.


Return to “Offtopic Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest