Weird transparency rendering.

Forum for general chit-chat or off-topic discussion.

Moderators: CEGUI MVP, CEGUI Team

renatoc8
Just popping in
Just popping in
Posts: 2
Joined: Mon Dec 25, 2006 08:22

Weird transparency rendering.

Postby renatoc8 » Tue Jan 02, 2007 09:52

Ok, i've come here because i just cannot figure this out by myself, and i was hoping someone here had a solution.

I have a directx engine in the works, and so far everything has been fine, so i finaly decided to give cegui a try, however it seems to do some weird things to the renderer. Bellow are some before and after pictures. Basically it makes some surfaces see-through, or semi-see-through, and you can see either the surface directly behind it or the skybox.

Before: Image
After:
Image

Before:
Image
After:
Image

I can init cegui fine, and the logs show nothing wrong. The problem apears as soon as the rendering line gets run: CEGUI::System::getSingleton().renderGUI();
One of our programmers suggested this could be a problem with alpha blending or depth test.

renatoc8
Just popping in
Just popping in
Posts: 2
Joined: Mon Dec 25, 2006 08:22

Postby renatoc8 » Fri Jan 05, 2007 02:54

Ok, granx pointed me towards depth testing, and it turned out to be correct. I just had to enable depth and allow for writing by using:

d3dDevice->SetRenderState(D3DRS_ZENABLE,D3DZB_TRUE);
d3dDevice->SetRenderState(D3DRS_ZWRITEENABLE,true);


Return to “Offtopic Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest