Mouse Disappears over Button?

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

User avatar
Gf11speed
Not too shy to talk
Not too shy to talk
Posts: 22
Joined: Mon Jun 13, 2005 17:51
Contact:

Mouse Disappears over Button?

Postby Gf11speed » Sun Jun 18, 2006 16:07

All of the sudden in my application, the mouse disappears whenever it is over a button. Any ideas as to what is going on? I tried searching the forum, but I did not find anything on this... eventhough it seems like it might be a common problem?
Syntasoft Games
www.syntasoft.com

Rackle
CEGUI Team (Retired)
Posts: 534
Joined: Mon Jan 16, 2006 11:59
Location: Montréal

Postby Rackle » Mon Jun 19, 2006 00:19

Your look 'n' feel or scheme probably does not define the cursor image for something like "mouse hovering on top". I'm sure someone can give the proper name, unless that's sufficient a tip for you to figure it out...

User avatar
Gf11speed
Not too shy to talk
Not too shy to talk
Posts: 22
Joined: Mon Jun 13, 2005 17:51
Contact:

Postby Gf11speed » Mon Jun 19, 2006 04:45

What is the name??? I'm trying to do this but it does not do anything (it does work for editboxes, however, which is where I got it in the first place -- in the .looknfeel file):

Code: Select all

<Property name="MouseCursorImage" value="set:GameLook image:MouseTextBar" />
Syntasoft Games

www.syntasoft.com

User avatar
Gf11speed
Not too shy to talk
Not too shy to talk
Posts: 22
Joined: Mon Jun 13, 2005 17:51
Contact:

Postby Gf11speed » Mon Jun 19, 2006 17:24

Ok problem solved. I was loading a cursor image that didn't exist after I had renamed some files. Thanks :)
Syntasoft Games

www.syntasoft.com


Return to “Help”

Who is online

Users browsing this forum: No registered users and 18 guests