Errors compiling IrrlichtRenderer

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

User avatar
kornerr
Not too shy to talk
Not too shy to talk
Posts: 41
Joined: Tue Apr 11, 2006 10:07
Location: Russia, Siberia, Kemerovo
Contact:

Errors compiling IrrlichtRenderer

Postby kornerr » Tue Aug 01, 2006 16:18

Code: Select all

irrlichtrenderer.cpp: In member function `virtual CEGUI::Texture*
   CEGUI::IrrlichtRenderer::createTexture()':
irrlichtrenderer.cpp:154: error: cannot allocate an object of type `
   CEGUI::IrrlichtTexture'
irrlichtrenderer.cpp:154: error:   because the following virtual functions are
   abstract:
../../include/CEGUITexture.h:122: error:        virtual void
   CEGUI::Texture::loadFromMemory(const void*, unsigned int, unsigned int,
   CEGUI::Texture::PixelFormat)
Open Source all the way, baby ;)
Opensource Game Studio

User avatar
lindquist
CEGUI Team (Retired)
Posts: 770
Joined: Mon Jan 24, 2005 21:20
Location: Copenhagen, Denmark

Postby lindquist » Tue Aug 01, 2006 16:23

looks like you need to get svn trunk

RC1 has a broken irrlicht renderer

User avatar
kornerr
Not too shy to talk
Not too shy to talk
Posts: 41
Joined: Tue Apr 11, 2006 10:07
Location: Russia, Siberia, Kemerovo
Contact:

Postby kornerr » Sat Sep 02, 2006 04:55

Please, modify ./configure checkings so that it compiles app NOT with gcc, but with g++! gcc can't see c++'s includes! and so, I can't compile irrlicht renderer, because it includes <new>, <cstring>, etc.
Or tell me how to do it.
Open Source all the way, baby ;)
Opensource Game Studio

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Sat Sep 02, 2006 15:15

It all works ok here (and for most other users, since we're not inundated with reports of this issue)...

What system are you using an what errors are you seeing specifically?

Thanks,

CE.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 11 guests