Trouble loading 'newer' scheme versions

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

Azure
Just popping in
Just popping in
Posts: 13
Joined: Thu Dec 28, 2006 22:37

Trouble loading 'newer' scheme versions

Postby Azure » Fri Dec 29, 2006 20:32

Im using a prebuilt Ogre SDK (Dagon v1.2.4) and I was unable to get the 'latest' CEGUI SDK to work, however the version that came with Ogre works fine. So ive been using that for the longest time, no trouble (with the default schemes that come with Ogre at least).

However, I tryed to load a layout that I created with the Layout Editor, and thats when the fun began. First, it complained that "WindowRendererSet" should be "WindowSet", not sure why that needed to change across versions, but I made the switch, and it 'took' the scheme ok... but NOW its complaining about some more semantics in the looknfeel ->

29/12/2006 13:15:55 (Error) Exception: Falagard::xmlHandler::elementStart - The unknown XML element 'PropertyLinkDefinition' was encountered while processing the look and feel file.


You wouldnt think the latest prebuilt CEGUI that came with the latest version of Ogre would be THIS out of date, but I guess it is? Please tell me I dont have to rebuild the latest Ogre and CEGUI from source, just to be able to use the layout editor and its new scheme format...

Im willing to do a little manual modification to the xml to get this to work. Any help greatly appreciated!

Azure
Just popping in
Just popping in
Posts: 13
Joined: Thu Dec 28, 2006 22:37

Postby Azure » Sat Dec 30, 2006 03:11

Well after doing some more research I see there are some major differences between previous versions and 0.5. And since the current version of Ogre isnt up to speed yet, that would explain all the trouble im having. The problem is, Eihort is so close (at least its supposed to be out soon), and I understand that DOES support CEGUI 0.5...

Seems silly to go through all the trouble of patching Ogre now...

I wonder, is there a earlier version of the layout editor I could use? One that exports a compatible layout format?

User avatar
martignasse
Just can't stay away
Just can't stay away
Posts: 227
Joined: Thu Apr 14, 2005 08:10
Location: Lyon, FRANCE

Postby martignasse » Sat Dec 30, 2006 09:05

hello azure,

if i remember, the cegui version in ogre dagon is the 0.4.1.

so, you have to update it with the 0.5 version if you want to directly use the layouts produced with the last layout editor version.

there is a thread about that on the ogre forums

http://www.ogre3d.org/phpBB2/viewtopic.php?t=21792

hope it help


Return to “Help”

Who is online

Users browsing this forum: No registered users and 7 guests