Bug in XML parser with linux and 0.5.0

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

vinvin
Just popping in
Just popping in
Posts: 7
Joined: Fri Mar 02, 2007 00:12
Location: Antibes, France
Contact:

Bug in XML parser with linux and 0.5.0

Postby vinvin » Fri Mar 02, 2007 00:31

I have this error I can't understand while loading TaharezLook.scheme:

02/03/2007 00:58:11 (InfL1) ---- CEGUI System initialisation completed ----
02/03/2007 00:58:11 (InfL1) ---- Version 0.5.0 ----
02/03/2007 00:58:11 (InfL1) ---- Renderer module is: CEGUI::OgreRenderer - Official Ogre based renderer module for CEGUI ----
02/03/2007 00:58:11 (InfL1) ---- XML Parser module is: CEGUI::XercesParser - Official Xerces-C++ based parser module for CEGUI ----
02/03/2007 00:58:11 (InfL1) ---- Scripting module is: None ----
02/03/2007 00:58:11 (InfL1) Attempting to load Scheme from file 'TaharezLook.scheme'.
02/03/2007 00:58:11 (InfL1) XercesParser::initialiseSchema - Attempting to load schema from file 'GUIScheme.xsd'.
02/03/2007 00:58:12 (InfL1) XercesParser::initialiseSchema - XML schema file 'GUIScheme.xsd' has been initialised.
02/03/2007 01:06:28 (Error) Exception: XercesParser::parseXMLFile - An error occurred at line nr. 11 while parsing XML file 'TaharezLook.scheme'. Additional information: Unknown element 'WindowRendererSet'
02/03/2007 01:06:28 (Error) Scheme::Scheme - loading of Scheme from file 'TaharezLook.scheme' failed.


Why the hell doesn't he knows WindowRendererSet ?
- WindowRendererSet is well defined in CEGUIScheme_xmlHandler.cpp
- the 11th line of TaharezLook.scheme is not that at all, WindowRendererSet is on the 5th and the 11th is the Titlebar.
- I'm using a just recompiled CEGUI from 0.5.0 release.
- It is used in an Ogre3D program, with OgreCEGUIRenderer, all are up to date.

I tried to gdb in the parser to see why it does that, I could only get to CEGUI::XercesParser::doParse (...) at CEGUIXercesParser.cpp:279, gdb doesn't have information to go deeper, in the parse() function.

Is there a special libxml version needed ? (I guess ./configure would have screamed)

Please help, it's driving me nuts :(

User avatar
Dalfy
CEGUI Team (Retired)
Posts: 130
Joined: Tue Oct 11, 2005 16:13
Location: Paris, FRANCE
Contact:

Postby Dalfy » Fri Mar 02, 2007 11:17

Have you check the version of the XSD files are they the sames as the one in the XMLRefSchema dir of CEGUI ?

Is there a special libxml version needed ? (I guess ./configure would have screamed)

You are using Xerces so libxml is not even use ! You can select the parser you want through the configure script option ?

There was error in the CEGUI-0.5.0 version when using Xerces are you using package CEGUI-0.5.0b ?

vinvin
Just popping in
Just popping in
Posts: 7
Joined: Fri Mar 02, 2007 00:12
Location: Antibes, France
Contact:

Postby vinvin » Fri Mar 02, 2007 13:25

I don't know right now for the XSD files, I can't check. I don't even know where they are btw.

I don't specially want to change the parser, but if xerces doesn't work, I will :) I thought libxml or something was used.

I think this is 0.5.0b indeed, as it comes from here : http://www.cegui.org.uk/wiki/index.php/ ... oads_0.5.0 (the first link)

vinvin
Just popping in
Just popping in
Posts: 7
Joined: Fri Mar 02, 2007 00:12
Location: Antibes, France
Contact:

Postby vinvin » Sat Mar 03, 2007 01:31

You were right, the XSD files were not up to date, because they are not used in Windows, and the program was working fine.
It is good now.
Sorry :(


Return to “Help”

Who is online

Users browsing this forum: Bing [Bot] and 13 guests