Tooltips not showing up

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

daves
Home away from home
Home away from home
Posts: 253
Joined: Thu Feb 02, 2006 20:12

Tooltips not showing up

Postby daves » Wed May 23, 2007 13:35

I'm trying to figure out the minimum that I have to do to have tooltips associated with my cegui widgets.

I've done the following and nothing works.

I call CEGUI::System::setDefaultToolTip("WindowsLook/Tooltip");
I set the tooltip text on my widget:

e.g. btn->setToolTipText("Hi");

When this didnt work I then associated the default tooltip with the button

btn->setTooltip(CEGUI::System::getSingleton().getDefaultTooltip());

What am I missing?

I'm using 0.5 btw.

User avatar
scriptkid
Home away from home
Home away from home
Posts: 1178
Joined: Wed Jan 12, 2005 12:06
Location: The Hague, The Netherlands
Contact:

Postby scriptkid » Wed May 23, 2007 14:03

Hi,

this link might mention something you have forgotten, such as injecting time maybe?

http://www.cegui.org.uk/wiki/index.php/Tooltips

HTH.

Kuehrli
Just popping in
Just popping in
Posts: 12
Joined: Tue May 22, 2007 14:03
Location: Linz, AT

Postby Kuehrli » Wed May 23, 2007 14:05

I am using

Code: Select all

   btn->setTooltipText("Test");
   btn->setTooltipType("WindowsLook/Tooltip");

without anything else (like setDefaultTooltip) and it works fine.

Rackle
CEGUI Team (Retired)
Posts: 534
Joined: Mon Jan 16, 2006 11:59
Location: Montréal

Postby Rackle » Wed May 23, 2007 14:35

May not be injecting time pulses (just like keyboard and mouse events).

daves
Home away from home
Home away from home
Posts: 253
Joined: Thu Feb 02, 2006 20:12

Postby daves » Wed May 23, 2007 16:17

ah.. never even knew about "injecting time" but that certainly makes sense given the nature of a tooltip... will try that.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 18 guests