DLL error when trying to run my project

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 19:25

Hi all,
I am just trying to put CEGUI into a DirectX 9 project (the simple sample project you get from the direct x sample browser)

however when i try to run it i get the error that the d3dx9d_40.dll was not found.

I am using CEGUI 0.6.2 and i am running visual studio's 2008.

Has anyone got any ideas? btw the error only started when i added the CEGUI DX 9 renderer.
Regards
Mark

Timo
Not too shy to talk
Not too shy to talk
Posts: 24
Joined: Sun Feb 14, 2010 09:38

Re: DLL error when trying to run my project

Postby Timo » Thu Apr 01, 2010 19:56

You need to update your DirectX runtime.

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 20:37

Hi,
I have updated the runtime and the sdk to the latest and yet i still have the same issue. any thoughts?
Regards
Mark

Timo
Not too shy to talk
Not too shy to talk
Posts: 24
Joined: Sun Feb 14, 2010 09:38

Re: DLL error when trying to run my project

Postby Timo » Thu Apr 01, 2010 21:00

Oh, sorry I didn't notice that was the debug DLL. I'm not absolutely sure, but i think you need to link d3dx9.lib instead of d3dx9d.lib in your project.

EDIT: It seems the debug DLLs are included in DX SDK, so I guess the best option would be to use them. Just copy them to a place where your program can find them. I've never use the debug libraries myself, I just always link the retail libraries cause I'm lazy. :)

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 21:27

Hi Timo,
What i have noticed is that it is asking for the _40.dll but i only have the _41.dll. Could it possibly be that the CEGUI dx9 render interface is made for a different version of the DX sdk?
Regards
Mark

Timo
Not too shy to talk
Not too shy to talk
Posts: 24
Joined: Sun Feb 14, 2010 09:38

Re: DLL error when trying to run my project

Postby Timo » Thu Apr 01, 2010 21:42

markblue777 wrote:Hi Timo,
What i have noticed is that it is asking for the _40.dll but i only have the _41.dll. Could it possibly be that the CEGUI dx9 render interface is made for a different version of the DX sdk?
Regards
Mark

If you're using the precompiled CEGUI binaries then I suppose it might require a debug DLL supplied with older version of the DXSDK. But if you compile CEGUI yourself it should work with any relatively new DXSDK version.

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 21:52

OK mate. i'll give it a go and see what happens. Thanks for the help man
Regards
Mark

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 22:12

still no joy after building them on my machine. any other ideas?
Regards
Mark

Timo
Not too shy to talk
Not too shy to talk
Posts: 24
Joined: Sun Feb 14, 2010 09:38

Re: DLL error when trying to run my project

Postby Timo » Thu Apr 01, 2010 22:19

So it still asks _40.dll after compiling CEGUI with latest DXSDK?

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 22:26

yeah

Timo
Not too shy to talk
Not too shy to talk
Posts: 24
Joined: Sun Feb 14, 2010 09:38

Re: DLL error when trying to run my project

Postby Timo » Thu Apr 01, 2010 22:49

Well that's really weird. If you did build it then it should now use D3dx9d_42.dll. (or whatever version you have)

So, all I can say is, make sure you built the right configuration (debug vs. debug_static), and that your project is actually using the new lib/dll you built.

markblue777
Just popping in
Just popping in
Posts: 8
Joined: Thu Apr 01, 2010 12:23

Re: DLL error when trying to run my project

Postby markblue777 » Thu Apr 01, 2010 22:54

ok then mate, cheers. I will give it another go and see what i can do.
Regards
Mark


Return to “Help”

Who is online

Users browsing this forum: No registered users and 9 guests