[Binary Issue] Dynamic Module failure

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

User avatar
klapeto
Just popping in
Just popping in
Posts: 2
Joined: Tue Jun 10, 2014 00:43
Location: Athens, Greece
Contact:

[Binary Issue] Dynamic Module failure

Postby klapeto » Fri Feb 20, 2015 13:48

Hello!

I am currently trying to release a binary package of my project, and I want to include the CEGUI shared libraries (along with others) on the package in order to create a portable package (I want to make sure it will run on the Institution's machines, so I have to make it portable since they do not allow to install anything). So I built the project and placed most of libraries used in a folder on the artifact's place and created a bash script to include the folder on the Shared library search path. So I booted to Fedora 21 x86-64, and tried to to run the project from there (my fedora installation has nearly none of my project's dependencies installed). The program loaded the libraries successfully and programmed run, but CEGUI threw an exception during initialization.

CEGUI resulted the Logfile below after this:

Code: Select all

20/02/2015 15:10:18 (Std)    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
20/02/2015 15:10:18 (Std)    +                     Crazy Eddie's GUI System - Event log                    +
20/02/2015 15:10:18 (Std)    +                          (http://www.cegui.org.uk/)                         +
20/02/2015 15:10:18 (Std)    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

20/02/2015 15:10:18 (Std)    CEGUI::Logger singleton created. (0x21da670)
20/02/2015 15:10:18 (Std)    ---- Started parse of CEGUI config file ----
20/02/2015 15:10:18 (Std)    ---- Finished parse of CEGUI config file ----
20/02/2015 15:10:18 (Error)   CEGUI::GenericException in function 'CEGUI::DynamicModule::DynamicModule(const CEGUI::String&)' (/home/klapeto/Ληφθέντα αρχεία/cegui-0.8.4/cegui/src/DynamicModule.cpp:222) : Failed to load module 'libCEGUIFreeImageImageCodec.so': /usr/local/lib/cegui-0.8/libCEGUIFreeImageImageCodec.so: cannot open shared object file: No such file or directory


No further info was written since the execution was aborted there because I don't handle the Exception during the initialization of CEGUI.
Please note that the same exception was thrown for the library 'libCEGUIExpatParser.so' but copying the library in the folder, fixed the problem. Doing the same for 'libCEGUIFreeImageCodec.so' however, did not fix it.

Here I quote part of a Logfile from a previous successful run on Linux-Mint 17.1 x86-64:

Code: Select all

11/02/2015 22:09:11 (Std)    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
11/02/2015 22:09:11 (Std)    +                     Crazy Eddie's GUI System - Event log                    +
11/02/2015 22:09:11 (Std)    +                          (http://www.cegui.org.uk/)                         +
11/02/2015 22:09:11 (Std)    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

11/02/2015 22:09:11 (Std)    CEGUI::Logger singleton created. (0x2a7ed20)
11/02/2015 22:09:11 (Std)    ---- Started parse of CEGUI config file ----
11/02/2015 22:09:11 (Std)    ---- Finished parse of CEGUI config file ----
11/02/2015 22:09:11 (Std)    
11/02/2015 22:09:11 (Std)    ********************************************************************************
11/02/2015 22:09:11 (Std)    * Important:                                                                   *
11/02/2015 22:09:11 (Std)    *     To get support at the CEGUI forums, you must post _at least_ the section *
11/02/2015 22:09:11 (Std)    *     of this log file indicated below.  Failure to do this will result in no  *
11/02/2015 22:09:11 (Std)    *     support being given; please do not waste our time.                       *
11/02/2015 22:09:11 (Std)    ********************************************************************************
11/02/2015 22:09:11 (Std)    ********************************************************************************
11/02/2015 22:09:11 (Std)    * -------- START OF ESSENTIAL SECTION TO BE POSTED ON THE FORUM       -------- *
11/02/2015 22:09:11 (Std)    ********************************************************************************
11/02/2015 22:09:11 (Std)    ---- Version: 0.8.4 (Build: Jan 15 2015 GNU/Linux g++ 4.9.2 64 bit) ----
11/02/2015 22:09:11 (Std)    ---- Renderer module is: CEGUI::OpenGLRenderer - Official OpenGL based 2nd generation renderer module.  TextureTarget support enabled via FBO extension. ----
11/02/2015 22:09:11 (Std)    ---- XML Parser module is: CEGUI::ExpatParser - Official expat based parser module for CEGUI ----
11/02/2015 22:09:11 (Std)    ---- Image Codec module is: FreeImageCodec - FreeImage based image codec ----
11/02/2015 22:09:11 (Std)    ---- Scripting module is: None ----
11/02/2015 22:09:11 (Std)    ********************************************************************************
11/02/2015 22:09:11 (Std)    * -------- END OF ESSENTIAL SECTION TO BE POSTED ON THE FORUM         -------- *
11/02/2015 22:09:11 (Std)    ********************************************************************************


The project as well as CEGUI was built on Linux-Mint 17.1 x86-64.
As far as I can understand, the paths are hard-coded into #defines during Cmake configuration process. That's what I think. So is there anyway to make the shared CEGUI libraries load properly, or I should fallback to Static linking CEGUI? Thanks in advance.

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: [Binary Issue] Dynamic Module failure

Postby Kulik » Mon Feb 23, 2015 14:55

Run

Code: Select all

ldd -r libCEGUIFreeImageCodec.so


Either the file itself or its dependency is not in PATH. That's why the loader can't find it.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 25 guests