"CEGUI_BIDI_SUPPORT" never defined

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

YaronCT
CEGUI Team
Posts: 448
Joined: Fri Jun 19, 2015 12:18
Location: Kiryat-Bialik, Israel

"CEGUI_BIDI_SUPPORT" never defined

Postby YaronCT » Mon Nov 23, 2015 18:11

Some places check whether "CEGUI_BIDI_SUPPORT" is defined, e.g. in "cegui/src/WindowRendererSets/Core/Editbox.cpp" in "FalagardEditbox::render":

Code: Select all

#ifdef CEGUI_BIDI_SUPPORT
    renderTextBidi(wlf, visual_text, text_area, text_offset);
#else
    renderTextNoBidi(wlf, visual_text, text_area, text_offset);
#endif


"CEGUI_BIDI_SUPPORT" is only defined in "Config.h.in":

Code: Select all

#cmakedefine CEGUI_BIDI_SUPPORT


However, it's never defined in the CMake files, therefore will never be defined in "Config.h", or anywhere. Shouldn't it be defined if and only if "CEGUI_USE_MINIBIDI" is true or "CEGUI_USE_FRIBIDI" is true?

YaronCT
CEGUI Team
Posts: 448
Joined: Fri Jun 19, 2015 12:18
Location: Kiryat-Bialik, Israel

Re: "CEGUI_BIDI_SUPPORT" never defined

Postby YaronCT » Mon Nov 23, 2015 18:12

Which also makes we wonder, if BiDi support is tested at all..?

User avatar
Ident
CEGUI Team
Posts: 1892
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: "CEGUI_BIDI_SUPPORT" never defined

Postby Ident » Wed Nov 25, 2015 19:12

I don't use it and never tested it. But I also changed nothing that could break it ;) Feel free to fix it.
CrazyEddie: "I don't like GUIs"


Return to “Help”

Who is online

Users browsing this forum: No registered users and 2 guests