Cannot build CEGUI on Antergos

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

Drumz93
Just popping in
Just popping in
Posts: 1
Joined: Wed Jun 14, 2017 12:27

Cannot build CEGUI on Antergos

Postby Drumz93 » Wed Jun 14, 2017 12:35

Hello everyone

I'm having some trouble while compiling CEGUI 0.8.7

I'm on Antergos (latest version), I have installed all dependencies and i still get these errors :

Code: Select all

/usr/bin/ld: CMakeFiles/toluappcegui-0.8.dir/tolua.c.o: référence au symbole non défini «lua_rawlen»
/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/../lib/liblua.so.5.3: error adding symbols: DSO missing from command line
collect2: erreur : ld a retourné 1 code d'état d'exécution
make[2]: *** [cegui/src/ScriptModules/Lua/support/tolua++bin/CMakeFiles/toluappcegui-0.8.dir/build.make:124: bin/toluappcegui-0.8] Error 1
make[1]: *** [CMakeFiles/Makefile2:895: cegui/src/ScriptModules/Lua/support/tolua++bin/CMakeFiles/toluappcegui-0.8.dir/all] Error 2
make: *** [Makefile:152: all] Error 2


Lib lua 5.1 is installed, tolua 5.3 is installed, conky-cairo is installed.

Thanks for helping

User avatar
Ident
CEGUI Team
Posts: 1806
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Cannot build CEGUI on Antergos

Postby Ident » Thu Jun 15, 2017 07:05

You might want to contact your packager. Seems like a packaging issue to me, or just a linking issue with tolua, as it seems to have issues adding the symbols from liblua? Not sure how this can even be the case. :pint: The issue has nothing to do with CEGUI itself, that is for sure.
CrazyEddie: "I don't like GUIs"


Return to “Help”

Who is online

Users browsing this forum: No registered users and 3 guests