[solved,sortof]Why can't the sample browser load any bloody pngs?

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

Just popping in
Just popping in
Posts: 6
Joined: Fri Apr 19, 2019 18:01

[solved,sortof]Why can't the sample browser load any bloody pngs?

Postby Damnit » Fri Apr 19, 2019 20:43

I ended up using the "unstable" development version, after pampering it's little butt a bit.
(There was some windows only code in it¹, and a few bugs)
So I guess the sample collectino in the "mature stable version" uses a different way of using IL/ILU.
How? i don't bloody know. That's this libraries motto for me.

"I don't bloody know what's going on. Just gotta pray to Odin that things work after trowling the online stuff in a circular loop."
That's the library in a nutshell for me. Still, I really do appreciate that it exists.
It's just super frustrating to get into, maybe it's not apparent to the old boy elite, or maybe I'm just a bumbling retard, that's fair, but boy, howdy, is it frustrating. Like, right now I want to keep a tooltip moving along with the mouse, and the only immediate fix I could think of, without having to deal with more in depth BS, was to update its position on every mouse move inject, after testing if it's actually visible. It works, but it's a bit laggy cause the positioning code has logic in it to prevent placing the tip in bad spots, which is nice. So sweaty. So warm. I should use CEGUI in the winter to save on heating...

I'm trying to use this praised and cherished and mature and battle proven library and I have to cross my fingers trying to make a moving tooltip work because I don't know if what I'm doing is right or wrong, deprecated but backwards compatible, cutting edge, unstable, replicated from somewhere else, etc. It's so exhausting. I don't know anythingggggggggg.

changeset: 6840:ce14e8f926a8:
/tmp/cegui-source/cegui/src/RendererModules/OpenGL/GL3Renderer.cpp:54:22: error: expected initializer before ‘OpenGlDebugCallback’
static void APIENTRY OpenGlDebugCallback( GLenum source, GLenum type, GLuint id, GLenum severity, GLsizei length, const GLchar* message, const void* userParam )

APIENTRY is windows stuff.

In file included from /tmp/cegui-source/cegui/src/RendererModules/Irrlicht/GeometryBuffer.cpp:31:
/tmp/cegui-source/cegui/include/CEGUI/RendererModules/Irrlicht/GeometryBuffer.h:32:10: fatal error: CEGUI/Rect.h: No such file or directory
#include "CEGUI/Rect.h"

Irrlicht module wants rect and vector which are now named differently, I cut those out of my build, etc. So yeah.

Probably some things I forgot that ruined the build.
Why is this damn product so resistant against my attempts to learn it?
So, the online documentation is patchy and confusing, to the extent that some tutorials casually throw in "ways to achieve things better than falagard" and so forth (stick to the fookin API you crabsniffer), so I thought I'd check out the sample browser and learn from there but, of course, alas.
Crazy Eddies GUI only works for those who are fully crazy, and I'm only nearly crazy from its usage.

CEGUI::RendererException in function 'virtual void CEGUI::OpenGLTexture::loadFromFile(const CEGUI::String&, const CEGUI::String&)' (/tmp/SBo/cegui-0.8.7/cegui/src/RendererModules/OpenGL/Texture.cpp:246) : DevILImageCodec - Official DevIL based image codec failed to load image 'SampleBrowser.png'.

If you're wondering why it's not "logo.png":
My first attempt to fix this dumdum of a dum was to excise the logo.png tumor, but, in CEGUI fashion, it had a secondary cancer ace up its deep brown hole.

To that I say:
Nibba, DevIl works, stop this BS. Load some damn pngs you bullfango of a knob sample browser.
Just to get this dookie working, maybe, at some point, I went on a IL and ILU testing spree, going through old and new alike, those old GL tuts (lazyfoo), DevIL samples themselves, my own cown, etc, it all worked. I don't know why the Cegui samples have to be pants on head mule about this.

Also, before I post the log (not that that will help anyway) for the future, name your damn releases, give them some damn nicknames or something so people can google that shiznit without losing their hair.

Odins freaking eye.

Anyway, the freaking log which will help NAUGHT cause, again, a piss.

There, enjoy your useless log.

Also, before you complain about me being too rude.

Imagine one of those little squares from the tutorial wiki where it says

Written for CEGUI 0.6
Works with versions 0.6.x (obsolete)

My patience was made obsolete, you'll have to rollback time to get it back.
Fair is fair, right?

Return to “Help”

Who is online

Users browsing this forum: Google [Bot] and 18 guests