Need help building CEGUI

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

dmytry
Just popping in
Just popping in
Posts: 3
Joined: Sat Jan 11, 2020 20:28

Need help building CEGUI

Postby dmytry » Sat Jan 11, 2020 21:05

I'm having issues building CEGUI. Specifically it seems like the SILLY library is not being built properly. Visual Studio 2019 Windows 8.1 OS.
I'm planning on using CEGUI with SDL2 and OPENGL.

I downloaded CEGUI from this: http://cegui.org.uk/download

I was following this video:
https://www.youtube.com/watch?v=mwf_gDVudsE

I built some portions of the library and
Running this code:
CEGUI::OpenGL3Renderer& cegui_renderer = CEGUI::OpenGL3Renderer::create(CEGUI::Sizef(800.f, 600.f));
cegui_renderer.enableExtraStateSettings(true);
CEGUI::System::create(cegui_renderer) ;

results in:
CEGUI::GenericException in function '__cdecl CEGUI::DynamicModule::DynamicModule
(const class CEGUI::String &)' (C:\Projects\Libraries\cegui\cegui-0.8.7\cegui\sr
c\DynamicModule.cpp:224) : Failed to load module 'CEGUISILLYImageCodec_d.dll': T
he specified module could not be found.

I do not see CEGUISILLYImageCodec_d.dll in cegui-0.8.7\build\bin

Here are some screenshots and errors from my projects:
CEGUI deps CMAKE/CMAKE output:
https://imgur.com/rYr6k0h
CEGUI-deps error for building SILLY project (rest build):
https://imgur.com/EBKGBvM

CEGUI Cmake:
https://imgur.com/8KhUSYU
CEGUI Cmake output:
https://imgur.com/pH6ituF

CEGUI visual studio build output:
https://imgur.com/sqkCVjo

User avatar
Ident
CEGUI Team
Posts: 1997
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Need help building CEGUI

Postby Ident » Sat Jan 11, 2020 21:14

Is there any chance you forgot to copy the dependencies folder over after building the dependencies?
CrazyEddie: "I don't like GUIs"

dmytry
Just popping in
Just popping in
Posts: 3
Joined: Sat Jan 11, 2020 20:28

Re: Need help building CEGUI

Postby dmytry » Sat Jan 11, 2020 22:33

I will double check when I get back. However, in the dependencies project SILLY project fails to build. All other projects including SILLY static build properly. Do both of them need to build for it work?

User avatar
Ident
CEGUI Team
Posts: 1997
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Need help building CEGUI

Postby Ident » Sat Jan 11, 2020 22:43

The dependencies have to build.
CrazyEddie: "I don't like GUIs"

dmytry
Just popping in
Just popping in
Posts: 3
Joined: Sat Jan 11, 2020 20:28

Re: Need help building CEGUI

Postby dmytry » Sat Jan 11, 2020 23:21

The cegui dependencies I unzip, then run cmake, then build the generated visual studio project. Am I missing any steps? Do I need to move something for dependcies to build? Im a bit confused why SILLY fails to build (the error message is pretty clear but not sure how to resolve it). Maybe Im missing some check boxes in the dependencies cmake or something?

User avatar
Ident
CEGUI Team
Posts: 1997
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Need help building CEGUI

Postby Ident » Sun Jan 12, 2020 00:27

Have you checked if jpeg lib was built successfully? Might be a naming issue of the output lib. Is the lib present?

You might also wanna try VS2017, i have not tried this with Vs2019 yet but I will do so in the future when I am done setting up gitlab for CEGUI - but that might eat up all my time for now
CrazyEddie: "I don't like GUIs"


Return to “Help”

Who is online

Users browsing this forum: No registered users and 11 guests