[SOLVED] ItemListBoxes not rendering last item

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

davislast19
Just popping in
Just popping in
Posts: 10
Joined: Mon Apr 10, 2017 21:08

[SOLVED] ItemListBoxes not rendering last item

Postby davislast19 » Sun Apr 05, 2020 00:25

I'm using CEGUI version 0.8.7, with the OpenGL3 renderer.

Similar to http://cegui.org.uk/forum/viewtopic.php?f=3&t=7083&p=33942&hilit=last+item+in+listbox#p33942, my ItemListBox was not rendering the last ItemEntry added to it. I tried the method of using

Code: Select all

invalidate()
as well as using

Code: Select all

notifyScreenAreaChanged()
to no avail. Finally, I decided that I'd just have an extra entry at the end so that that wouldn't render, but my actual entries would, and when I used sortList(), all of my entries began showing up.

The fix was simply to choose a sorting method, and then call sortList() when I was finished adding entries.

I've added this here so that future 0.8.7 users can find it. Let me know if this isn't the right place.

User avatar
Ident
CEGUI Team
Posts: 1997
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: [SOLVED] ItemListBoxes not rendering last item

Postby Ident » Sun Apr 05, 2020 03:07

Can this be fixed in code?
CrazyEddie: "I don't like GUIs"

davislast19
Just popping in
Just popping in
Posts: 10
Joined: Mon Apr 10, 2017 21:08

Re: [SOLVED] ItemListBoxes not rendering last item

Postby davislast19 » Sun Apr 05, 2020 23:27

I'm sorry, I'm not quite sure what you mean by "in code." I (by random luck) discovered this fix, and made it in my own C++ code.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 13 guests