Can't run ceed 0.8.0 on Ubuntu 16.04 [Solved]

Forum for support and development discussion regarding the python based unified editor tool for CEGUI, known as CEED.

Moderators: CEGUI Team, CEGUI MVP

Matthieu Dalissier
Just popping in
Just popping in
Posts: 3
Joined: Sun Jun 19, 2016 14:15

Can't run ceed 0.8.0 on Ubuntu 16.04 [Solved]

Postby Matthieu Dalissier » Sun Jun 19, 2016 14:54

Hello,

I have the problem that i can't start ceed 0.8.0. I compiled CEGUI 0.8.7 with the OpenGL and OpenGL3 dependencies and the python modules on Ubuntu 16.04 with gcc 4.9.3

The compilation is going fine, but i when i try to start ceed i get the following error:

Code: Select all

PYTHONPATH=../../cegui-0.8.7/build/lib:../:$PYTHONPATH python2 ./ceed-gui
Traceback (most recent call last):
  File "./ceed-gui", line 89, in <module>
    main()
  File "./ceed-gui", line 30, in main
    if prerequisites.check():
  File "/home/matt/Projects/3rdParty_Projects/ceed-0.8.0/ceed/prerequisites.py", line 67, in check
    if not canImportPyCEGUI():
  File "/home/matt/Projects/3rdParty_Projects/ceed-0.8.0/ceed/prerequisites.py", line 59, in canImportPyCEGUI
    __import__("PyCEGUIOpenGLRenderer")
RuntimeError: extension class wrapper for base class CEGUI::Renderer has not been created yet
Last edited by Matthieu Dalissier on Thu Jun 30, 2016 10:01, edited 2 times in total.

YaronCT
CEGUI Team
Posts: 436
Joined: Fri Jun 19, 2015 12:18
Location: Holon, Israel

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby YaronCT » Sun Jun 19, 2016 15:33

@Ident: is ceed supposed to work at all? I've never tried it myself..

User avatar
Ident
CEGUI Team
Posts: 1657
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby Ident » Sun Jun 19, 2016 16:07

YaronCT wrote:@Ident: is ceed supposed to work at all? I've never tried it myself..

Yes, of course it is supposed to work...

Never seen the error, Kulik should be able to help
CrazyEddie: "I don't like GUIs"

YaronCT
CEGUI Team
Posts: 436
Joined: Fri Jun 19, 2015 12:18
Location: Holon, Israel

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby YaronCT » Sun Jun 19, 2016 17:13

@Matthieu Dalissier: I'll look into it.

Matthieu Dalissier
Just popping in
Just popping in
Posts: 3
Joined: Sun Jun 19, 2016 14:15

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby Matthieu Dalissier » Sun Jun 19, 2016 17:32

@YaronCT: Ok, thanks.

iceiceice
Not too shy to talk
Not too shy to talk
Posts: 27
Joined: Thu Jul 09, 2015 10:20

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby iceiceice » Tue Jun 28, 2016 17:42

@Matthew Dalissier:

I had a friend who was having trouble installing CEED on ubuntu about a year ago. The thing is that it uses python, but it needs to find C++ libraries, so if your python isn't searching the right paths, then you get such errors. And whether you get such errors depends on whether you installed CEGUI system-wide (`make install`) or just compiled it in your home directory (must modify`runwrapper.sh` script to get the search path right).

I made a complete install notes here:

http://cegui.org.uk/wiki/CEED#Complete_ ... for_Ubuntu

It should work on 16.04 also afaik.

Matthieu Dalissier
Just popping in
Just popping in
Posts: 3
Joined: Sun Jun 19, 2016 14:15

Re: Can't run ceed 0.8.0 on Ubuntu 16.04

Postby Matthieu Dalissier » Thu Jun 30, 2016 10:00

@iceiceice: Thanks a lot, :D i was able to solve it by running the script in an empty directory. I assume i simply forgot some dependency... Ceed is starting up now.

If one is just using "apt-get python python-pyside pyside-tools python-opengl libboost-python-dev" for the dependencies and then sets the OpenGl and OpenGl3 option as well as the build for the python modules in the cmake-gui, cegui gets compiled but ceed just shows the error message i stated in the first post.


Return to “Official Unified CEGUI Editor Tool (CEED)”

Who is online

Users browsing this forum: Google [Bot] and 2 guests