Page 1 of 1

Snapshot7 release

Posted: Sun Apr 22, 2012 16:56
by Kulik
New snapshot has been released. Archives provide testing sample data with CEGUI 0.7 and CEGUI 0.8 datafiles.

There have been 29 issues fixed from the last snapshot6. The most remarkable change is probably the new property set inspector by Pavlos Toubolidis and initial animation editing (though it's just a tech preview for now, expect issues!).

Grab the source tarball, Windows standalone binaries or OSX application bundle (experimental) at ... snapshot7/

Known issues:
Due to refactoring changes in CEGUI related to Checkbox, ToggleButton and Radiobox, there may be issues when loading layouts with any of them.
Animation editor often crashes when closing it.

Incomplete list of changes:
- 0000523: [Animation editing] Reusable timeline (Kulik) - resolved.
- 0000709: [Documentation] Create a user manual about what's implemented and won't be changed in the near future (cca 6 months) (Kulik) - resolved.
- 0000759: [Documentation] Create a developer manual (Kulik) - resolved.
- 0000761: [Imageset editing] Imagesets are serialised as version 2 but the version attribute is missing (Kulik) - resolved.
- 0000756: [Layout editing] Fix 0.7 layout compatibility (Kulik) - resolved.
- 0000758: [Layout editing] Live preview is broken because of GUI context changes in CEGUI (Kulik) - resolved.
- 0000753: [General] Add compatibility layers for CEGUI scheme versions 4 and 5 (Kulik) - resolved.
- 0000752: [General] Use the compatibility machinery for imagesets when loading project resources (Kulik) - resolved.
- 0000754: [General] Use the compatibility machinery for fonts when loading project resources (Kulik) - resolved.
- 0000755: [Compatibility layers] ceed-migrate is broken beyond belief (Kulik) - resolved.
- 0000751: [Imageset editing] Add compatibility support for imageset version 1 and 2, fix imageset editor (Kulik) - resolved.
- 0000750: [General] Fix CEED to work with latest CEGUI GUI context additions (Kulik) - resolved.
- 0000692: [General] Implement revert file (Kulik) - resolved.
- 0000695: [Layout editing] Trying to save when layout isn't opened (because no project has been opened) throws an exception (Kulik) - resolved.
- 0000731: [Layout editing] Use absolute positions and sizes by default (Kulik) - resolved.
- 0000630: [Layout editing] Undoing while editing a property won't notify the property editor to update it's value to the undone value (pav) - resolved.
- 0000491: [General] Property inspecting systems reworking (pav) - resolved.
- 0000705: [Layout editing] Falagard properties being serialized as PropertyDefinitions, wtf?! (Kulik) - resolved.
- 0000668: [Layout editing] Ember GUI data project is loaded but all layouts are black (Kulik) - resolved.
- 0000704: [General] Attempting to bind a shortcut results in an exception (Kulik) - resolved.
- 0000703: [General] Add FPS to CEGUI Debug Info (Kulik) - resolved.
- 0000702: [Animation editing] Exception thrown when animation editor is initialised with no project opened (Kulik) - resolved.
- 0000696: [General] Dumping CEGUI log into stdout is not a good idea! (Kulik) - resolved.
- 0000701: [General] The application doesn't remember it's geometry and state (Kulik) - resolved.
- 0000700: [General] CEED crashes when quitting and project requiring tabs are opened with changes (Kulik) - resolved.
- 0000698: [General] Inject real time pulses to make "ambient" animations work in layout editor (Kulik) - resolved.
- 0000697: [General] Saving layouts with no root widget raises an exception if compatibility layers are used (Kulik) - resolved.
- 0000706: [Layout editing] Image field not taking input (Kulik) - closed.
- 0000555: [General] Gesture scrolling in MacOSX zooms in imageset and layout editing modes (Kulik) - closed.

Plans for snapshot8: ... sion_id=31

Enjoy and please report any problems!

Re: Snapshot7 release

Posted: Fri Apr 27, 2012 11:37
by Ronald Wendt

first i want to thank everyone supporting CEED: Snapshot this tool enormously helps to speed up development with CEGUI !

As we are using this combination for our current project once more i came across one thing i am really missing to have a better work flow within snapshot.

Is it possible to include a navigation window that displays the image while one edits a taharezlook.imagset ? I have to arrange a lot of small areas within a huge image and its really annoying to use the scrollbars in every instance.

Besides that i really enjoy working with this tool.

Ronald Wendt

Re: Snapshot7 release

Posted: Fri Apr 27, 2012 13:17
by Kulik
Thanks for the feedback, great that this tool is useful for people.

You mean a smaller image that you drag to navigate? Like ... n_gimp.gif ?

Feel free to create a ticket in mantis (same login info as on this forum will work), maybe someone will look at it. Have you tried panning with the middle mouse button?

Re: Snapshot7 release

Posted: Sun Apr 29, 2012 07:06
by jarwulf
cool, if more people knew about this cegui itself would become much more popular

Re: Snapshot7 release

Posted: Sun Apr 29, 2012 08:33
by Kulik
jarwulf wrote:cool, if more people knew about this cegui itself would become much more popular

I hereby promote you to CEGUI Marketing General! Market! MARKET FAST! :lol:

Re: Snapshot7 release

Posted: Thu May 03, 2012 10:39
by Ronald Wendt

Kulik wrote:Thanks for the feedback, great that this tool is useful for people.

It defnitly is, it helps a great deal.

Kulik wrote:You mean a smaller image that you drag to navigate? Like ... n_gimp.gif ?

YES ! Thats it. I am spoiled by several paint/photo programs where this is common, i guess i am very used to work with this.

Kulik wrote:Feel free to create a ticket in mantis (same login info as on this forum will work), maybe someone will look at it.

OK, i will try that, maybe i add some small other things.

Kulik wrote:Have you tried panning with the middle mouse button?

No, didn't know that feature, thanks for the hint.


Ronald Wendt

Re: Snapshot7 release

Posted: Fri May 18, 2012 16:52
by yacper
Wonderful job!
I've left CE quite a while, and today, when i came aroud and saw this fabulous tool, you guys really surprise me! This is the right one i want to develope when i use CEGUI to develope my first game!
Two years before, i dived into the 3d stuff, and never have time again to polish my job. Anyway, when i saw your work, i realize that i don't need to anymore!
Bless you all!

Re: Snapshot7 release

Posted: Thu May 24, 2012 18:28
by czuger

I am attempting to use this release but have hit a roadblock.
- We use cegui 0.7
- We use a lot of 'pixmap' type fonts, generated by a tool.

CEED refuses to load the imagesets associated with these fonts. It loads the imagesets fine otherwise.

Scheme-> imageset (this works)
Scheme -> Font -> imageset (this does not work, CEED complains that imageset version must be 2)

If I use the provided migrate tool to migrate my imageset files, CEED can open them, but the application can not load them anymore (they are now version 2, which CEGUI 0.7 does not know anything about)?

To reproduce this in your distributed sample data:
Add <Font Filename="FairChar-30.font" /> to any .scheme file distributed in the 0.7 sample folder (I tried OgreTray.scheme). Open the provided 0.7 sample project. It will throw an exception upon loading complaining it needs version 2 imagesets.

This is a total showstopper, since I either have files I can edit but not load, or can't edit but can load. Any suggestions for a workaround?

Edit*: I found this thread which discusses the same problem: viewtopic.php?f=15&t=6104&p=28870#p28870. Am I to understand the workaround here is to:
1) Convert existing imageset files -> version 2.0
2) Convert all attribute names back to CamelCase?

Is there any chance of a quick fix of some kind here?


Re: Snapshot7 release

Posted: Fri May 25, 2012 06:57
by Kulik

the best workaround I can think of is to make a script that runs ceed-migrate on your data. Migrate them to version 2, edit edit edit, migrate them back to version 1 and load into your app. No information will be lost, the migration is 1:1.

I will make a fix for this, sorry that it slipped to the release. It will have to be a proper fix though, this is CEGUI directly fopening the file so no string source transformation tricks will do :-(

There is a mantis ticket for this already but I am on GPRS so looking for it now and linking to it would be impractical.

Re: Snapshot7 release

Posted: Thu Jun 21, 2012 16:50
by czuger
Hi Kulik,

I saw the note on your issue ticket on this, and it does not appear that it is going to get fixed anytime soon. I have implemented your suggested workaround (script to convert to version 2, edit, script to convert to version 1, run).
Although not the prettiest solution, it works for now.

If anyone else has this problem, this Lua script will do it for you. Uses luarocks and luafilesystem.

Code: Select all

require "luarocks.loader"
require "lfs"

rootPath = "C:/dev/metalhead/cpp-ws/BigFly/bigfly/game/assets/bigfly/gui"
conversionToolpath = 'C:/dev/utils/ceed-snapshot8-win32/ceed-snapshot8/ceed-migrate.exe'
conversionTargetType = 'runnable'

function recurse_convert(path)
    for file in lfs.dir(path) do
        if file ~= "." and file ~= ".." then
            local f = path..'/'..file
            print ("\t "..f)
            local attr = lfs.attributes (f)
            assert (type(attr) == "table")
            if attr.mode == "directory" then
                recurse_convert (f)
                if string.match(file, '.imageset') then
                   -- Convert to temporary
                   local sourceFile = f
                   local destinationFile = f .. '.conv'
                   local convertToType = 'CEGUI imageset 2'
                   if conversionTargetType == 'runnable' then
                        convertToType = 'CEGUI imageset 1'
                   local command = conversionToolpath .. ' --targetType \"' .. convertToType .. '\" imageset ' .. sourceFile .. ' ' .. destinationFile
                   -- Delete original
                   -- Rename converted
                   os.rename(destinationFile, sourceFile)