Page 1 of 1

Snapshot8 release

Posted: Sun Jun 10, 2012 20:52
by Kulik
New snapshot has been released. Archives provide testing sample data with CEGUI 0.7 and CEGUI 1.0 datafiles.

There have been 35 issues fixed from the last snapshot7. The goal of the release was to provide a more reliable and better performing application. The resources load way faster, the logging slowdown has been fixed. There have been some user experience improvements as well, including the ability to change background of embedded CEGUI to a checkerboard. This is also the first release that supports CLI options for ceed-gui.

Grab the source tarball, Windows standalone binaries or OSX application bundle at ... snapshot8/

Incomplete list of changes:
- 0000821: [Imageset editing] saving to the imagefile (from adobe photoshop) while ceed is open leads to an exception (Kulik) - resolved.
- 0000823: [General] Editing colours in the main CEED preferences renders the entire app unresponsive (CrazyEddie) - resolved.
- 0000820: [Animation editing] Enable zooming in the animation preview (Kulik) - resolved.
- 0000589: [Layout editing] Resolution settings do not persist in a project (Kulik) - resolved.
- 0000818: [General] Support "negative zoom" (Kulik) - resolved.
- 0000817: [Imageset editing] Support editing of the new autoScaled values (Kulik) - resolved.
- 0000586: [Imageset editing] Zoom should be on mouse wheel + ctrl (Kulik) - resolved.
- 0000760: [Compatibility layers] Get all compat layers checked using XSD for verification (Kulik) - resolved.
- 0000812: [Layout editing] Copying widget to its parent triggers an exception (Kulik) - resolved.
- 0000811: [General] Offer -debug argument to verbosely output to terminal (Kulik) - resolved.
- 0000806: [Animation editing] Always destroy the temporary animation instance when finalising animation editing (Kulik) - resolved.
- 0000804: [Layout editing] Checkerboard background as an option for layout editing (Kulik) - resolved.
- 0000801: [General] Provide CLI parameters to open a project, load files, etc.. to ceed-gui (Kulik) - resolved.
- 0000802: [CLI tools] Metaimageset compiler outputs version 1 imageset (Kulik) - resolved.
- 0000800: [General] Reopen tabs requiring a project opened after resources are reloaded (Kulik) - resolved.
- 0000799: [Layout editing] Optionally hide nested auto windows if they don't contain any non-auto window descendants (Kulik) - resolved.
- 0000797: [Compatibility layers] Version checks parse the entire data using DOM, we should use SAX instead (Kulik) - resolved.
- 0000795: [Project management] Reloading all resources probably leaks (Kulik) - resolved.
- 0000798: [General] Logging gets slower as more messages get logged (Kulik) - resolved.
- 0000796: [General] Speed up loading by using cElementTree instead of ElementTree (Kulik) - resolved.
- 0000786: [Project management] Make sure to save portable paths (Kulik) - resolved.
- 0000540: [Layout editing] Support for ScrollablePane and other widgets that put children into __auto_content_pane__ or similar (Kulik) - resolved.
- 0000790: [Imageset editing] Imageset Editing Window mini-preview of images has white background (Kulik) - resolved.
- 0000787: [Compatibility layers] Core/SystemButton related issues (Kulik) - resolved.
- 0000792: [Layout editing] Segfault related to opening and closing projects (Kulik) - resolved.
- 0000782: [General] CEGUI 0.8 should read 1.0 (Kulik) - resolved.
- 0000767: [Project management] Exception raised when opening a project file and CEED is on a different drive than data (Kulik) - resolved.
- 0000770: [Compatibility layers] Warn when opened file is incompatible with project's target CEGUI (Kulik) - resolved.
- 0000780: [Project management] Remove project name (Kulik) - resolved.
- 0000777: [Project management] Force the ".project" extension when creating a new project (Kulik) - resolved.
- 0000779: [Compatibility layers] CEGUI/Checkbox target type got renamed to CEGUI/ToggleButton (Kulik) - resolved.
- 0000768: [Layout editing] Could not Input Chinese Text ? (Kulik) - resolved.
- 0000819: [Imageset editing] Changing imageset image doesn't remove it from the filesystem watcher (Kulik) - closed.
- 0000757: [Compatibility layers] Compatibility layers only take the "value" attribute into account when migrating image reference values (Kulik) - closed.
- 0000766: [General] Offer newbie help when no tabs are opened (Kulik) - closed.

Plans for snapshot9 will end up at ... sion_id=34

Enjoy and please report any problems!

Re: Snapshot8 release

Posted: Mon Jun 11, 2012 14:50
by Shlldn
Hello and thanks for this new release. I had never posted on the forum before, but now I feel I should give you some user feedback. I'm not sure whether I should make it a new topic or not, but I'll leave this here since it's mostly relevant to this release.
I should warn you that this may look like a rant, but I is not; I fully understand it's an independent project, with a lot of work accomplished by several contributors, and I respect that.

I compiled the current stable release of CEGUI (0.7.6) from source on Windows, to use it in an already existing project. Then, when I finally managed to do so, I tried using CEED's previous version (snapshot7), only to realize I was unable to do anything since it kept throwing exceptions. That's why I decided to download the source code of the last CE Layout Editor to work with it instead and try to add some features.
Then, you released this new snapshot, and at first I was really satisfied with the improvements that had been made. It felt more polished, I only encountered one exception-throwing case (I'll make sure to open a ticket later), and I told myself "that's it, I'll use this tool since it's been greatly improved". But one issue made me reconsider it: I'm still unable to display a simple image. I had the same problem with snapshot7, it had been reported by another user on the forum (here), and a ticket had been opened on the bug tracker (here), but it seems it was closed without having been actually fixed. I've tried using custom imagesets and imagesets included with CEED in my layouts, and I've tried opening included layouts that used included imagesets, but to no avail.

The issue seems to be the same as the one reported here: CEED (or CEGUI) doesn't seem to parse correctly the StaticImage's "Image" value property, and when setting the "image" field manually in CEED, I see the same result in the "code" panel.
The following is the input code from CEED's DragDropDemo layout file, set for version 0.7:

Code: Select all

<Window Type="WindowsLook/StaticImage" Name="DragContainer1/Image" >
    <Property Name="UnifiedAreaRect" Value="{{0,0},{0,0},{1,0},{1,0}" />
    <Property Name="Image" Value="set:DriveIcons image:Lime" />
    <Property Name="MousePassThroughEnabled" Value="True" />

This is the input code for version 1.0:

Code: Select all

<Window name="Image" type="WindowsLook/StaticImage">
    <Property name="Area" value="{{0,0},{0,0},{1,0},{1,0}" />
    <Property name="Image" value="DriveIcons/Lime" />
    <Property name="MousePassThroughEnabled" value="True" />

This is the resulting code when loaded in CEED, set for version 0.7:

Code: Select all

<Window Type="WindowsLook/StaticImage" Name="DragContainer1/Image" >
    <Property Name="UnifiedAreaRect" Value="{{0,0},{0,0},{1,0},{1,0}" />
    <Property Name="MousePassThroughEnabled" Value="True" />

And this is the code for version 1.0:

Code: Select all

<Window type="WindowsLook/StaticImage" name="Image" >
    <Property name="Area" value="{{0,0},{0,0},{1,0},{1,0}}" />
    <Property name="MousePassThroughEnabled" value="True" />

No big difference between 0.7 and 1.0: the property disappears, and the image isn't displayed.

I honestly wish I'm missing something obvious, because I can't see how such a visible issue would have made it to snapshot8 without being spotted by the developers. Otherwise, it would mean a very important and basic feature can't be used in CEED, which would stop people from using CEED, or even CEGUI.
I hope I'm the only one having this problem now, and I'm ready to talk about it with a developer.

Anyway, thank you for your hard work, and sorry if I'm heavily mistaken.

Re: Snapshot8 release

Posted: Mon Jun 11, 2012 15:07
by Kulik
Hi Shlldn,
feedback is always great, thanks. This thread is appropriate, no worries.

The situation regarding Image properties is not ideal, I know. I will try to describe the reasons.

CEED only knows about images that are loaded in one of the schemes that are part of your project. CEGUI internally stores Images as pointers to the Image instances, therefore CEED can't store any Image it doesn't know about. When CEGUI loads back code you provide (or even parses a property that you edit), it tries to figure out the pointer, if such Image is not found, it sets the pointer to 0, writes it to the log and outputs an error log message.

The whole thing would be way way better if CEED had an image property editor that would only allow you to put a valid image name there.

tl;dr: Make sure you are loading the appropriate imageset in your scheme, make sure you are typing the image name exactly. Check logs (Help->CEGUI debug info).

HTH, I will target image property inspector to snapshot9 so that this gets done for the next release.

tickets created for this:

EDIT: and a CEGUI ticket to avoid losing resource ref info like this in the future

Re: Snapshot8 release

Posted: Wed Jun 13, 2012 09:28
by Shlldn

I figured I would post a reply since you were really helpful both here and on irc yesterday, and to provide some feedback about the story's "conclusion".
It turns out that the .scheme file was indeed the root of the problem, since the imageset containing the images wasn't included in any of the schemes in the project. What is still troubling me is that I faced this issue after opening a project file that was included in CEED's samples directory. I expected the sample to work without any change needed, but maybe I was mistaken again.

What happened next is I added the "DriveIcons" imageset to the WindowsLook scheme (I don't think it's a good way to edit a "standard" sheme, but I just wanted to see if that would do the trick) through CEED, but then I faced another issue: my file had been emptied by CEED after saving and closing it. As discussed on irc, I filed a bug report on CEGUI's Mantis bugtracker, and kulik told me that CEED's simple text editor wasn't tested, and shouldn't really be used to edit anything. So, be extra careful with your files, and for now avoid using CEED to edit your scheme and looknfeel files, for example. I want to be clear on this: the issue only arises in "simple" text editing mode, I'm not talking about the "code" tab when editing something like a .layout file, don't avoid using CEED for that issue alone.

I then restored the empty file, made my changes with notepad, and sure enough, after reloading the resources in CEED, the pictures appeared.

I hope I made myself clear in this post.

Thanks again for your help kulik, I think I have every info I need to work with CEGUI/CEED now.

Re: Snapshot8 release

Posted: Thu Jun 21, 2012 17:41
by czuger

Kudos on this release. I was stuck at snapshot-5 for a long time, due to show-stoppers in later releases.
This latest release is working great so far for my layout editing needs. You have really addressed a lot of the annoying usability issues and crashed, I can work reasonably efficiently within the tool now. Thnx!


Re: Snapshot8 release

Posted: Thu Jun 21, 2012 19:26
by czuger
A word of caution to everyone using this release:

The option: "prevent manipulator overlap" in Edit/Preferences/Layout editing dramatically slows down layout editing. In my case, for a layout containing ~50 widgets, the performance drops from 70fps to 0.05fps, turning this option makes it run fast again :)


Re: Snapshot8 release

Posted: Sat Jun 23, 2012 13:56
by Kulik
czuger: Great that it works for you

"Prevent manipulator overlap" works in a very sub-optimal way. It uses stencil volumes to "stencil out" the parts that are overlapped by something else. Very CPU intensive. Finding the rects to stencil out is expensive as well. It could be improved to work fast but it's not a priority ATM.