Python 'ascii codec can't decode byte 0xe9' error at startup

Forum for support and development discussion regarding the python based unified editor tool for CEGUI, known as CEED.

Moderators: CEGUI MVP, CEGUI Team

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Python 'ascii codec can't decode byte 0xe9' error at startup

Postby Bertram » Thu Sep 25, 2014 13:10

Hi there, :)

I'm reporting the following error as I was unable to find similar posts. My apologize if it is already know.

With the latest stable CEED version (0.8.0) windows zip file, I've got the following error at startup (in a message box):

Code: Select all

Traceback(most recent call last):
File "C:\Python27\lib\site-packages\cx_Freeze\initscripts\Console.py", line 27, in <module>
File "bin/ceed-gui", line 89, in <module>
File "bin/ceed-gui", line 30, in main
File "g:\Libraries\CEGUI\ceed\prerequisites.py" line 117, in check
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 173: ordinal not in range(128)


Using the unstable zip snapshot on the same machine, CEED is starting just fine.

Feel free to ask if you need more info. :)

Best regards,

User avatar
Ident
CEGUI Team
Posts: 1821
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Ident » Mon Sep 29, 2014 12:06

We did not manage to reproduce this.

What exact OS do you use and what is your paths in your project?
CrazyEddie: "I don't like GUIs"

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Tue Sep 30, 2014 15:26

Hi ident, :)

Ident wrote:did not manage to reproduce this.
What exact OS do you use and what is your paths in your project?


- OS: Windows XP. (I'll try tonight on 7)
- I've downloaded this one: http://sourceforge.net/projects/crayzed ... p/download
- I have uncompressed it (using right-click, extract to...) on the desktop (end path: C:\Documents and Settings\me\Desktop\ceed-0.8.0-win32)
- Then I opened the new folder and tried to run: ceed-gui.exe
The message box appears immediately.

When doing the exact same with this one, it is working: http://sourceforge.net/projects/crayzed ... p/download

Best regards,

User avatar
Ident
CEGUI Team
Posts: 1821
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Ident » Tue Sep 30, 2014 15:40

Cant reproduce on Windows 7 with the CEED 0.8.0 Release.

Are you actually set up as "me" on windows or did you replace your actual name in the path youz gave us there? If you did replace your user name, could you tell us at least if it contains any non-ascii characters and if yes paste them here?
CrazyEddie: "I don't like GUIs"

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Thu Oct 02, 2014 15:58

Good question. Indeed I've replaced the user by 'me', but the user was 'yohann', so no non-ASCII character AFAIK.

I'll also check on Win7 asap (this time for real).

Best regards,

User avatar
Ident
CEGUI Team
Posts: 1821
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Ident » Sun Oct 05, 2014 17:35

Any news on this?
CrazyEddie: "I don't like GUIs"

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Kulik » Tue Oct 07, 2014 09:26

This really is an annoying issue. It seems some exception is being raised but it contains text that can't be interpreted as ASCII. We really want to see what's inside the exception.

I will change the prerequisites code to be more robust and just print out the broken ASCII instead of complaining about it. It should be fixed for the next version.

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Sat Oct 11, 2014 07:05

Hi guys. :)

Sorry for the slow answer. I just tested on a Win7 64bit version. Exact same bug at start.

Also, the snapshot 11 is starting just fine.

I'll gladly test the next snapshot and report any error or log file you could request.

Best regards,

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Kulik » Sat Oct 11, 2014 20:11

We need to fix it, that's why we need better info about what actually you are running into.

Very likely it's some nasty exception having invalid message that's the culprit.

User avatar
Ident
CEGUI Team
Posts: 1821
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Ident » Sat Oct 11, 2014 20:47

But why cant i reproduce...
CrazyEddie: "I don't like GUIs"

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Kulik » Sun Oct 12, 2014 11:18

Maybe you have en_US Windows while Bertram has something with non-ASCII characters?

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Mon Oct 13, 2014 18:53

Hi :)

Kulik wrote:Maybe you have en_US Windows while Bertram has something with non-ASCII characters?

Both were french edition of Windows, indeed. I guess fr_FR ones for both. Maybe "Français" is the culprit word, for instance?

Best regards,

User avatar
Ident
CEGUI Team
Posts: 1821
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Ident » Mon Oct 13, 2014 19:03

Sure, that's a non-Ascii symbol.
CrazyEddie: "I don't like GUIs"

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Mon Oct 13, 2014 19:17

Hi,

I checked here: http://doc.infosnel.nl/extreme_utf-8.html
The 0xe9 character seems to be a 'é'.

Hope this can help.

Best regards,

Bertram
Quite a regular
Quite a regular
Posts: 73
Joined: Wed Oct 02, 2013 14:46

Re: Python 'ascii codec can't decode byte 0xe9' error at sta

Postby Bertram » Wed Nov 26, 2014 14:01

Hi there,

I'm bumping the thread but with proactive thoughts, don't worry.
I wondered whether there were a way to compile/run the project to get the file triggering the crash on Windows.
I've seen pdb, but it seems I need to change the python scripts and I don't know whether it's feasible.

The fact is I'm still worth peanuts in python even if I decided it was time to give it a try...
So if you've got explanation on how I could get info on the crash, I'll take and use them.

Best regards,


Return to “Official Unified CEGUI Editor Tool (CEED)”

Who is online

Users browsing this forum: No registered users and 1 guest