Can't get CEED running on Arch Linux [Solved]

Forum for support and development discussion regarding the python based unified editor tool for CEGUI, known as CEED.

Moderators: CEGUI MVP, CEGUI Team

Robert42
Just popping in
Just popping in
Posts: 5
Joined: Sat Nov 22, 2014 08:54

Can't get CEED running on Arch Linux [Solved]

Postby Robert42 » Sat Nov 22, 2014 15:07

Hello I am trying to get CEED to run on my Arch Linux system,

As the ceed AUR package is out of date since 2012, I don't want to use it.

First try: Using the cegui package from arch Linux

The Steps I've done are based on http://cegui.org.uk/wiki/CEED#Arch_Linux, I have installed the packages

  • cegui
  • python-pyside (AUR) contained a python2-pyside package
  • python2-pyside-tools (AUR)
  • python2-opengl

I have downloaded the CEED tarball from http://sourceforge.net/projects/crayzed ... /CEED/0.8/

I tried to execute from the terminal with the bin directory as workingdir by executing the following commands:

Code: Select all

$ ./runwrapper.sh
$ ./ceed-gui


Executing ceed-gui fails with the error output:
Following problems found:
PyCEGUI was found but PyCEGUIOpenGLRenderer is missing! CEED can't render embedded CEGUI without it. (exception: /usr/lib/python2.7/site-packages/cegui-0.8/PyCEGUIOpenGLRenderer.so: undefined symbol: _ZN5CEGUI18OpenGLRenderTargetINS_12RenderTargetEED2Ev)
Your environment doesn't meet critical prerequisites! Can't start!


I've verified, that the PyCEGUIOpenGLRenderer.so file does exist:

Code: Select all

$ cd /usr/lib/python2.7/site-packages/cegui-0.8/
$ ls
PyCEGUIOgreRenderer.so  PyCEGUIOpenGLRenderer.so  PyCEGUI.so


Second Try: Trying to compile it by myself:

The next thing I've tried was to compile CEGUI by myself (just like described in the wiki, by cloning using hg clone and the v0-8 branches for both, cegui and ceed). After successfully building, I've set the PYTHONPATH environment variable point towards the build/lib directory (yes, I've verified, that the PyCEGUI.so file exists in that directory). However, when running, the prerequisites still aren't met:
Following problems found:
PyCEGUI package is missing! PyCEGUI provides Python bindings for CEGUI, the library this editor edits assets for, see cegui.org.uk. (exception: dynamic module does not define init function (initPyCEGUI))
Your environment doesn't meet critical prerequisites! Can't start!


After trying and googling, I am out of ideas :( Is there anyone out there who was able to get ceed run recently on Arch Linux?
Last edited by Robert42 on Sun Nov 23, 2014 14:10, edited 1 time in total.

Robert42
Just popping in
Just popping in
Posts: 5
Joined: Sat Nov 22, 2014 08:54

Re: Can't get CEED running on Arch Linux

Postby Robert42 » Sun Nov 23, 2014 13:19

OK, I've written a shell script, to make my second attempt easy to reproduce. They commands are basically taken from the wiki page.

Code: Select all

#!/bin/bash

rm -rf CEED
mkdir CEED
cd CEED

hg clone https://bitbucket.org/cegui/cegui
hg clone https://bitbucket.org/cegui/ceed

cd ceed
hg update v0-8
cd ../
cd cegui
hg update v0-8
cd ../

mkdir cegui/build
cd cegui/build

cmake -DCEGUI_BUILD_PYTHON_MODULES=ON -DCEGUI_BUILD_RENDERER_OPENGL=ON -DCEGUI_BUILD_RENDERER_OPENGL3=ON -DCEGUI_BUILD_RENDERER_OGRE=OFF -DCEGUI_SAMPLES_ENABLED=OFF ../
make -j4

cd ..

cd ../ceed/bin
PYTHONPATH=../../cegui/build/lib:../:$PYTHONPATH python2 ./ceed-gui


This are the differences to the wiki:
  • I've added one cd .. to step out from the build directory before going to the ceed directory.
  • To speed up compiling, I've disabled the Ogre renderer -DCEGUI_BUILD_RENDERER_OGRE=OFF
  • To prevent compile errors because of mixing glfw2 and 3, I've simply disabled the samples -DCEGUI_SAMPLES_ENABLED=OFF


Compiling was successful.

Executing ceed was not:

Code: Select all

Following problems found:
PyCEGUI package is missing! PyCEGUI provides Python bindings for CEGUI, the library this editor edits assets for, see cegui.org.uk. (exception: dynamic module does not define init function (initPyCEGUI))
Your environment doesn't meet critical prerequisites! Can't start!


The CMake output looks suspicious:

Code: Select all

  File "<string>", line 1
    import distutils.sysconfig; print distutils.sysconfig.get_python_lib(plat_specific=True, prefix="")
                                              ^
SyntaxError: invalid syntax


This is the full CMake Output:

Code: Select all

-- The C compiler identification is GNU 4.9.2
-- The CXX compiler identification is GNU 4.9.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found PCRE: /usr/lib64/libpcre.so 
-- Found FREETYPE: /usr/lib64/libfreetype.so 
-- Could NOT find MINIZIP (missing:  MINIZIP_LIB MINIZIP_H_PATH)
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28")
-- checking for module 'fribidi'
--   found fribidi, version 0.19.6
-- Found FRIBIDI: TRUE 
-- Performing Test ICONV_LIB_GLIBC
-- Performing Test ICONV_LIB_GLIBC - Success
-- Performing Test CEGUI_ICONV_USES_CONST_INBUF
-- Performing Test CEGUI_ICONV_USES_CONST_INBUF - Failed
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Found OpenGL: /usr/lib64/libGL.so 
-- Found GLEW: /usr/lib64/libGLEW.so 
-- Found GLM: /usr/include 
-- Found GLFW: /usr/lib64/libglfw.so 
-- Could NOT find DIRECTXSDK (missing:  DIRECTXSDK_LIB_PATH DIRECTXSDK_H_PATH DIRECTXSDK_MAX_D3D)
-- Could NOT find D3DX11EFFECTS (missing:  D3DX11EFFECTS_LIB D3DX11EFFECTS_H_PATH)
-- Could NOT find IRRLICHT (missing:  IRRLICHT_LIB IRRLICHT_H_PATH)
-- Found OGRE: /usr/local/lib/libOgreMain.so 
-- Boost version: 1.57.0
-- Found the following Boost libraries:
--   thread
--   system
-- Found OIS: /usr/lib64/libOIS.so 
-- Could NOT find DIRECTFB (missing:  DIRECTFB_LIB DIRECTFB_H_PATH)
-- Could NOT find OPENGLES (missing:  OPENGLES_LIB)
-- Found EXPAT: /usr/lib64/libexpat.so 
-- Could NOT find XERCESC (missing:  XERCESC_LIB XERCESC_H_PATH)
-- Found LibXml2: /usr/lib64/libxml2.so (found version "2.9.2")
-- Found TINYXML: /usr/lib64/libtinyxml.so 
-- Performing Test TINYXML_API_TEST
-- Performing Test TINYXML_API_TEST - Success
-- Could NOT find RAPIDXML (missing:  RAPIDXML_H_PATH)
-- Found IL: /usr/lib64/libIL.so 
-- Found ILU: /usr/lib64/libILU.so 
-- Found FREEIMAGE: /usr/lib64/libfreeimage.so 
-- Found SILLY: /usr/lib64/libSILLY.so 
-- Could NOT find CORONA (missing:  CORONA_LIB CORONA_H_PATH)
-- Could NOT find PVRTOOLS (missing:  PVRTOOLS_LIB PVRTOOLS_H_PATH)
-- Found LUA51: /usr/lib64/liblua5.1.so 
-- Could NOT find TOLUAPP (missing:  TOLUAPP_LIB TOLUAPP_H_PATH)
-- Found PythonInterp: /usr/bin/python (found version "3.4.2")
-- Found PythonLibs: /usr/lib64/libpython3.4m.so (found version "3.4.2")
-- Boost version: 1.57.0
-- Found the following Boost libraries:
--   python
--   unit_test_framework
--   system
--   timer
-- Found Doxygen: /usr/bin/doxygen (found version "1.8.8")
-- Found GTK2_GTK: /usr/lib64/libgtk-x11-2.0.so 
  File "<string>", line 1
    import distutils.sysconfig; print distutils.sysconfig.get_python_lib(plat_specific=True, prefix="")
                                              ^
SyntaxError: invalid syntax
-- Configuring done
-- Generating done
-- Build files have been written to: /home/robert/Software/Tools/ceed-test/CEED/cegui/build


So I took a look into the CMake Cache and baam: PYTHON_EXECUTABLE is set to a path to the Version 3 of Python. I am taking a break now, but I will take a further look, whether enforcing Python2 will help.

If I succeed, I will let you know and update the Wiki.

Robert42
Just popping in
Just popping in
Posts: 5
Joined: Sat Nov 22, 2014 08:54

Re: Can't get CEED running on Arch Linux [Solved]

Postby Robert42 » Sun Nov 23, 2014 14:10

Ok, I got CEED running. I've read the right section multiple times in the wiki, but however, I've always overead the note regarding python 3 -- no wonder I got no answer :oops:

For future Arch Linux Users with the same Problem: This are the shell commands I've used to get CEED running:

Code: Select all

#!/bin/bash

rm -rf CEED
mkdir CEED
cd CEED

hg clone https://bitbucket.org/cegui/cegui
hg clone https://bitbucket.org/cegui/ceed

cd ceed
hg update v0-8
cd ../
cd cegui
hg update v0-8
cd ../

mkdir cegui/build
cd cegui/build

cmake -DCEGUI_BUILD_PYTHON_MODULES=ON -DCEGUI_BUILD_RENDERER_OPENGL=ON -DCEGUI_BUILD_RENDERER_OPENGL3=ON -DCEGUI_BUILD_RENDERER_OGRE=OFF -DCEGUI_SAMPLES_ENABLED=OFF -DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib64/python2.7 ../
make -j4

cd ..

cd ../ceed/bin
PYTHONPATH=../../cegui/build/lib:../:$PYTHONPATH python2 ./ceed-gui


The new commands I've added are:

Code: Select all

-DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib64/python2.7


I am going to do the following changes to the Wiki:
  • Emphasis the note regarding Python3 so future Arch users are less probably to overread it
  • Update the names of the AUR dependencies
  • add a note about the PYTHON_INCLUDE_DIR and the PYTHON_LIBRARY variables
Edit: I can't login to the Wiki :(

User avatar
Ident
CEGUI Team
Posts: 1870
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Can't get CEED running on Arch Linux [Solved]

Postby Ident » Sun Nov 23, 2014 15:50

Robert42 wrote:no wonder I got no answer :oops:

The reason you got no answer is because I have no idea about Linux and Kulik (mpreisler) is usually doing fun stuff during the weekend (this seems to exclude CEGUI support). I can only help with Windows setups for CEED (I wrote a concise guide for that purpose). You would probably gotten an answer on monday or so. But you managed to solve this yourself! Big thanks for adding the solution. Also constructive changes to the wiki are heavily encouraged so go wild.

Robert42 wrote:Edit: I can't login to the Wiki :(

Did you use forum account and pw? I just logged into the Wiki successfully.
CrazyEddie: "I don't like GUIs"

Robert42
Just popping in
Just popping in
Posts: 5
Joined: Sat Nov 22, 2014 08:54

Re: Can't get CEED running on Arch Linux [Solved]

Postby Robert42 » Sun Nov 23, 2014 16:21

Ident wrote:
Robert42 wrote:Edit: I can't login to the Wiki :(

Did you use forum account and pw? I just logged into the Wiki successfully.


Yes, I've tried using the same username and password as to the forum.

Finally after changing my password to a simpler one, I was able to log in and do the changes.
It looks, like not all passwords are supported by the wiki. I can send you my old (not used anymore) passwords which weren't compatible to the wiki, in case you or another admin wants to take a look at it.
Last edited by Robert42 on Sun Nov 23, 2014 16:24, edited 1 time in total.

User avatar
Ident
CEGUI Team
Posts: 1870
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Can't get CEED running on Arch Linux [Solved]

Postby Ident » Sun Nov 23, 2014 16:23

We were not aware of this issue. Send me a private message please.
CrazyEddie: "I don't like GUIs"

Robert42
Just popping in
Just popping in
Posts: 5
Joined: Sat Nov 22, 2014 08:54

Re: Can't get CEED running on Arch Linux [Solved]

Postby Robert42 » Wed Nov 26, 2014 22:43

So this is my final script to install ceed on linux. It also installs a desktop file integrating ceed into the main menu

Code: Select all

#!/bin/bash

rm -rf CEED
mkdir CEED
cd CEED

hg clone https://bitbucket.org/cegui/cegui
hg clone https://bitbucket.org/cegui/ceed

cd ceed
hg update v0-8
cd ../
cd cegui
hg update v0-8
cd ../

mkdir cegui/build
cd cegui/build

cmake -DCEGUI_BUILD_PYTHON_MODULES=ON -DCEGUI_BUILD_RENDERER_OPENGL=ON -DCEGUI_BUILD_RENDERER_OPENGL3=ON -DCEGUI_BUILD_RENDERER_OGRE=OFF -DCEGUI_SAMPLES_ENABLED=OFF -DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib64/python2.7 ../
make -j4

cd ..

cd ../ceed/bin

PWD=$(pwd)
echo "#!/bin/bash" > start-ceed.sh
echo "cd ${PWD}" >> start-ceed.sh
echo "PYTHONPATH=../../cegui/build/lib:../:$PYTHONPATH python2 ./ceed-gui" >> start-ceed.sh
chmod +x start-ceed.sh

ICON=${PWD}/../data/icons/ceed.png

DESKTOPFILE=~/.local/share/applications/ceed.desktop
echo "[Desktop Entry]" > $DESKTOPFILE
echo "Name=CEED" >> $DESKTOPFILE
echo "Exec=${PWD}/start-ceed.sh" >> $DESKTOPFILE
echo "Icon=$ICON" >> $DESKTOPFILE
echo "Type=Application" >> $DESKTOPFILE
echo "Categories=Development" >> $DESKTOPFILE
echo "NoDisplay=false" >> $DESKTOPFILE

muammar
Just popping in
Just popping in
Posts: 1
Joined: Thu Aug 25, 2011 20:36

Re: Can't get CEED running on Arch Linux [Solved]

Postby muammar » Wed Mar 23, 2016 16:50

Hi,

I think I am getting this problem also:

Code: Select all

Following problems found:
PyCEGUI was found but PyCEGUIOpenGLRenderer is missing! CEED can't render embedded CEGUI without it. (exception: /usr/lib/python2.7/dist-packages/cegui-0.8/PyCEGUIOpenGLRenderer.so: undefined symbol: _ZN5CEGUI18OpenGLRenderTargetINS_12RenderTargetEED2Ev)
Your environment doesn't meet critical prerequisites! Can't start!


I am the maintainer of CEGUI in debian, and in the following link you can see the DEB_CMAKE_EXTRA_FLAGS:

http://anonscm.debian.org/cgit/collab-maint/cegui-mk2.git/tree/debian/rules

And the dependencies installed:

http://anonscm.debian.org/cgit/collab-maint/cegui-mk2.git/tree/debian/control

Does anybody know how to solve this problem?. Thanks!

User avatar
Ident
CEGUI Team
Posts: 1870
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: Can't get CEED running on Arch Linux [Solved]

Postby Ident » Tue Mar 29, 2016 17:50

@muammar this problem has popped up before but Kulik and I don't know how to solve this specific occurrence you have. I know this is not helpful but I thought that is better than not answer which would make us look like we didn't care. We do care but we have no clue as of now.

The general issue is that the constructor is not public. That's something we also can#t change without breaking ABI. We will do things differently in 1.0 though.
CrazyEddie: "I don't like GUIs"

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: Can't get CEED running on Arch Linux [Solved]

Postby Kulik » Tue Mar 29, 2016 18:13

Hi muammar,
I am sorry but I don't know the solution of that. I remember solving this in the past but forgot the solution.

I would start by demangling the symbol, looking into why it's not exported AND why PyCEGUI needs it.


Return to “Official Unified CEGUI Editor Tool (CEED)”

Who is online

Users browsing this forum: No registered users and 2 guests