Mangled text after move to 0.5.0 rc1 [SOLVED]

For help with anything that CEGUI doesn't offer straight out-of-the-box, e.g.:
- Implementation of new features, such as new Core classes, widgets, WindowRenderers, etc. ...
- Modification of any existing features for specific purposes
- Integration of CEGUI in new engines or frameworks and writing of new plugins (Renderer, Parser, ...) or modules

Moderators: CEGUI MVP, CEGUI Team

Just popping in
Just popping in
Posts: 5
Joined: Thu Jul 06, 2006 21:59

Mangled text after move to 0.5.0 rc1 [SOLVED]

Postby enkd » Tue Jul 11, 2006 23:51

Having a strange problem which started when I moved to 0.5.0 RC1 (from 0.4.1).

Everything appears fine EXCEPT that all text is mangled. I've tried using several different versions of freetype to no avail. Seems to occur with ALL truetype fonts.

images seem to render fine (buttons look correct, etc.)

using OpenGL renderer

any ideas?

edit: solved by setting the OpenGL GL_UNPACK_ROW_LENGTH to 0 in the rendering loop with a call to glPixelStorei()

Return to “Modifications / Integrations / Customisations”

Who is online

Users browsing this forum: No registered users and 7 guests