I wish there wouldn't be separate types for size and point data. They are both just 2D-vectors after all so why bother? How about using HLSL-style naming conventions instead, as they're getting increasingly popular.
Size -> float2
Point -> float2
----
float2 temp(0.1f,0.1f);
float x=temp[0];
float y=temp[1];
//and or
float x=temp.x;
float y=temp.y;
Cheers
Size and Point data types.
Moderators: CEGUI MVP, CEGUI Team
Return to “Bug Reports, Suggestions, Feature Requests”
Who is online
Users browsing this forum: No registered users and 2 guests