[Solved] Sample Framework Build Failed (dxerr.lib)

If you found a bug in our library or on our website, please report it in this section. In this forum you can also make concrete suggestions or feature requests.

Moderators: CEGUI MVP, CEGUI Team

Alundra
Not too shy to talk
Not too shy to talk
Posts: 33
Joined: Mon Jun 30, 2014 03:29

[Solved] Sample Framework Build Failed (dxerr.lib)

Postby Alundra » Mon Jun 30, 2014 03:37

Hi,
"dxerr.lib" has to be removed from the project of CEGUISampleFramework to avoid the build error.
This build failed is from the git repository.
When I launch the exe, the application can't run "0xc000007b".

lucebac
Just can't stay away
Just can't stay away
Posts: 193
Joined: Sat May 24, 2014 21:55

Re: CEGUI Sample Framework Build Failed

Postby lucebac » Mon Jun 30, 2014 13:06

Hi,
assuming you meant the bitbucket repository, which version of CEGUI are you using (default branch or v0-8 branch)?

Alundra
Not too shy to talk
Not too shy to talk
Posts: 33
Joined: Mon Jun 30, 2014 03:29

Re: CEGUI Sample Framework Build Failed

Postby Alundra » Mon Jun 30, 2014 13:54


lucebac
Just can't stay away
Just can't stay away
Posts: 193
Joined: Sat May 24, 2014 21:55

Re: CEGUI Sample Framework Build Failed

Postby lucebac » Mon Jun 30, 2014 14:13

After a bit of googleing for "windows crash 0xc000007b" i found out that you maybe mix 32bit and 64bit libraries/exes in your build.
You said that you removed "dxerr.lib" and then it worked for you. Is it possible that you use a 64bit version of DX SDK and a 32bit version of cegui?

User avatar
Ident
CEGUI Team
Posts: 1871
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: CEGUI Sample Framework Build Failed

Postby Ident » Mon Jun 30, 2014 15:21

Your bug report doesn't help us at all. http://www.cegui.org.uk/phpBB2/viewtopi ... =10&t=3351
CrazyEddie: "I don't like GUIs"

Alundra
Not too shy to talk
Not too shy to talk
Posts: 33
Joined: Mon Jun 30, 2014 03:29

Re: CEGUI Sample Framework Build Failed

Postby Alundra » Mon Jun 30, 2014 16:07

Using Visual C++ 2013 "dxerr.lib" is not present so just removed from build and the build worked.
About the error you right, I used the application "depends" and he shows error about x64 dll used.
And apparently some dll missing too : http://uppix.com/f-ceguidll53b18bb80016e3ce.png.
Last edited by Alundra on Mon Jun 30, 2014 16:31, edited 1 time in total.

lucebac
Just can't stay away
Just can't stay away
Posts: 193
Joined: Sat May 24, 2014 21:55

Re: CEGUI Sample Framework Build Failed

Postby lucebac » Mon Jun 30, 2014 16:13

Hm - I use VS13 too and I do not get a crash like you described.
My build process works fine and SamplesFramework does its job perfectly.

User avatar
Ident
CEGUI Team
Posts: 1871
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: CEGUI Sample Framework Build Failed

Postby Ident » Mon Jun 30, 2014 16:25

Ident wrote:Your bug report doesn't help us at all. http://www.cegui.org.uk/phpBB2/viewtopi ... =10&t=3351

I hate having to repeat myself for no good reason, but there you go: We need: (MINIMUM) platform, IDE, error description (callstack)

also obviously: dont mix 32bit and 64bit


dxerr lib has nothing to do with visual studio. it is a directx library. i m not sure why you are implying it was related - can you explain to us why you think its related to your vs version?
See:
- http://blogs.msdn.com/b/chuckw/archive/ ... x-sdk.aspx
- http://blogs.msdn.com/b/chuckw/archive/ ... r-lib.aspx
CrazyEddie: "I don't like GUIs"

Alundra
Not too shy to talk
Not too shy to talk
Posts: 33
Joined: Mon Jun 30, 2014 03:29

Re: CEGUI Sample Framework Build Failed

Postby Alundra » Mon Jun 30, 2014 16:42

About the "dxerr.lib" it's because now directx is part of visual c++ and dxerr is not in it apparently, but just removed from build resolved the problem.
I have launched the SampleFramework from visual c++ using debug and that works all good, I don't understand why.
I have 10 FPS using Direct3D 11 Renderer on Windows Seven x64 on the main menu of SampleFramework.

User avatar
Ident
CEGUI Team
Posts: 1871
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: CEGUI Sample Framework Build Failed

Postby Ident » Mon Jun 30, 2014 17:36

Having low framerates in the quite complicated SampleBrowser (it renders to fullscreen textures and then uses these textures inside the previews) is expected in Debug mode. It should run smoothly in Release.

Also, If you open a Sample it should run with some hundreds or even thousands of FPS, depending on the specific Sample used. Also this whole discussion is unrelated to the initial issue you were describing. I am looking into the dxerr problem.
CrazyEddie: "I don't like GUIs"

User avatar
Ident
CEGUI Team
Posts: 1871
Joined: Sat Oct 31, 2009 13:57
Location: Austria

Re: CEGUI Sample Framework Build Failed

Postby Ident » Mon Jun 30, 2014 23:11

I looked into the dxerr linking issue. While it still shouldnt have caused the error you described, I found out that the "dxerr" library can be removed without problems. It was probably a leftover from the old D3D11 Renderer before i rewrote the whole Renderer so that it wouldn't rely on any of those extra libraries anymore. I tested my changes in VS2008 and also encountered another minor issue with the direct3d11 renderer and fixed that too.

Bottom line: "dxerr.lib" is not required in the new D3D11 Renderer and has now been as a dependency, here is my commit: https://bitbucket.org/cegui/cegui/commi ... fd940949ee
Commit hash: c308c82
CrazyEddie: "I don't like GUIs"

Alundra
Not too shy to talk
Not too shy to talk
Posts: 33
Joined: Mon Jun 30, 2014 03:29

Re: [Solved] Sample Framework Build Failed (dxerr.lib)

Postby Alundra » Tue Jul 01, 2014 02:19

Great job


Return to “Bug Reports, Suggestions, Feature Requests”

Who is online

Users browsing this forum: No registered users and 2 guests