CEImagesetEditor cannot load vanilla.tga

Use this forum for:
- Discussion regarding unofficial CEGUI related tools, scripts and utilities.
- User to user help for the obsoleted CELayoutEditor and CEImagesetEditor tools.

Moderators: CEGUI MVP, CEGUI Team

Just popping in
Just popping in
Posts: 5
Joined: Sat Aug 20, 2011 22:30

CEImagesetEditor cannot load vanilla.tga

Postby caburfoot » Sun Aug 21, 2011 20:06

I've tried examing posts, but I don't see any discussion of the issue. I'be build the CEimagesetEditor 0.7.1. And tring to learn how it works, opened the CELayoutEditor vanilla.imageset and taz

While it opened the file, I got the following error -
EditorGLCanvas::setImage - Error: DefaultResourceProvider::load: vanilla.tga does not exist.

THis is not true. Debugging shows that the name passed to the load call doesn't include the path to the XML file. I thought about modifying the code, but as I'm just beginning with CEGUI, I thought I'd share the info. It would seem that on load or on save the current working dir MAY need to be set and unset.

Open to guidance if I've overlooked something. I did read about loading the scheme, but I'm NOT loading from a display perspective, I'm loading from the CEImagesetEditor.

Guidance appreciated.

Posts: 812
Joined: Tue Jun 03, 2008 23:59
Location: USA

Re: CEImagesetEditor cannot load vanilla.tga

Postby Jamarr » Mon Aug 22, 2011 19:01

Please make sure you post in the appropriate sub-forum next time. Thank you.
If somebody helps you by replying to your thread, upvote him/her as a thanks! Make sure to include your CEGUI.log and everything you tried when posting! And remember that we are not magicians!

Return to “Unofficial CEGUI-Related Tools”

Who is online

Users browsing this forum: No registered users and 2 guests