Consider dropping VC 2003 (7.1) support

Official announcements from the CEGUI project.

Moderator: CEGUI Team

Which Microsoft compiler are you using?

Poll ended at Mon Jan 12, 2009 11:17

VC 2003 (7.1)
1
10%
VC 2005 (8)
3
30%
VC 2008 (9)
6
60%
 
Total votes: 10

User avatar
scriptkid
Home away from home
Home away from home
Posts: 1178
Joined: Wed Jan 12, 2005 12:06
Location: The Hague, The Netherlands
Contact:

Consider dropping VC 2003 (7.1) support

Postby scriptkid » Mon Dec 29, 2008 11:17

Hi all,

Note: this message is only relevant to Windows users.

For the 0.7 release we consider to drop VC7.1 support, for the following reasons:

1) The size of SDKs; they are huge to upload. They weight around 180MB, which is about six times the size of the VC8 and VC9 versions.
2) Looking at the download stats at SF, the number of VC8 and VC9 users is roughly twice the amount of the VC7.1 users.
3) VC7 is nearing its 6th birthday, which is pretty old in terms of software tools.
4) VC8 and 9 have free Express editions including Service Packs and so.

Feel free to comment and (de)motivate the support for VC7.1.

Please let us know, thanks :)
Check out my released snake game using Cegui!

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

Postby Pompei2 » Tue Dec 30, 2008 20:52

Hello,

It seems that either I am too dumb, or I can not give my vote? I just see the question and the score, which is all zeros.

I would vote for throwing the visual studio 2003 into the garbage. Anyone who still wants (or needs to) have that, can still compile the libs from source, it's not that hard to do it.

User avatar
scriptkid
Home away from home
Home away from home
Posts: 1178
Joined: Wed Jan 12, 2005 12:06
Location: The Hague, The Netherlands
Contact:

Postby scriptkid » Wed Dec 31, 2008 11:35

Mmm that's odd. I just tested myself, and i see a '1' for VC8. I double-checked the message, and i think it's okay.

If others have issues too, please post.

About compiling the libs by yourself: you are right. I still have VC7.1 installed, so it's a little effort to hit the compile button now and then. We can keep the premake files; it's mainly the SDK we'd like to get rid off :)
Check out my released snake game using Cegui!

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

Postby Pompei2 » Wed Dec 31, 2008 14:40

Huh very strange, I deleted all my cookies but still can't vote. (I know how to vote usually.)
Btw, now I see 1 vote too.
Doesn't matter, I would have voted for VS9

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Wed Dec 31, 2008 16:22

Hey guys, I voted VC9 and it worked ok. Maybe it's a user-level issue? Can anyone else, who is not an admin or moderator, please comment? Cheers :)

CE.

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Wed Dec 31, 2008 16:29

CrazyEddie wrote:Hey guys, I voted VC9 and it worked ok. Maybe it's a user-level issue? Can anyone else, who is not an admin or moderator, please comment? Cheers :)

CE.

Yep I can not vote.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Wed Dec 31, 2008 16:40

Ok, thanks. I have updated the permissions, it should work ok now.

Sorry for the inconvenience :)

CE.

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Wed Dec 31, 2008 16:45

Thanks I have the option of voting yet I can not vote for what I want, as I currently support the use of all three versions in projects I make.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Wed Dec 31, 2008 16:49

I currently support the use of all three versions

In cases like this, I suggest voting for the lowest version that you support; one of the central ideas of the poll is to give an indication of the number of users still desiring support for the outdated VC++ version.

HTH

CE

dmail
Quite a regular
Quite a regular
Posts: 46
Joined: Mon Nov 27, 2006 16:49

Postby dmail » Wed Dec 31, 2008 19:15

2) Looking at the download stats at SF, the number of VC8 and VC9 users is roughly twice the amount of the VC7.1 users.

Just out of interest, are you getting this figure from the dependencies packages? Because what I see is
MSCV Downloads
7.1 1194
8.0 2804
9.0 1580

User avatar
scriptkid
Home away from home
Home away from home
Posts: 1178
Joined: Wed Jan 12, 2005 12:06
Location: The Hague, The Netherlands
Contact:

Postby scriptkid » Thu Jan 01, 2009 15:05

@CE: Thanks for fixing it. It could have been caused by me moving the thread.

Just out of interest, are you getting this figure from the dependencies packages?


I looked at the 'downloads' column for the 0.6.2 package, which shows (for the SDKs):
7.1 152
8.0 273
9.0 273

For 0.6.1, which exists longer, the values are different:
7.1 1048
8.0 2280
9.0 1780

Which suggest that the biggest difference lies between VC7 and VC8, with over twice the amount of users.

Also, to repeat: dropping VC7 mainly concerns SDK users. If we still have many VC7 users, we can keep supporting the premake files for a bit longer.
Check out my released snake game using Cegui!

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Postby CrazyEddie » Thu Jan 01, 2009 16:48

scriptkid wrote:@CE: Thanks for fixing it.

No problemo.
scriptkid wrote:It could have been caused by me moving the thread.

Nah, it was my fault :) When I liberalised the permissions in this forum - allowing users to reply to posts - I failed to also update the permission that allows them to vote in polls :oops:

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

Postby Pompei2 » Fri Jan 02, 2009 12:52

Yup, It works now. I voted VC9

Pompei2
Home away from home
Home away from home
Posts: 489
Joined: Tue May 23, 2006 16:31

Postby Pompei2 » Fri Feb 13, 2009 19:12

VC 2003 (7.1) 10% [ 1 ]
VC 2005 (8) 30% [ 3 ]
VC 2008 (9) 60% [ 6 ]

Soo what will you do with these results now?

User avatar
gring
Not too shy to talk
Not too shy to talk
Posts: 21
Joined: Tue Mar 18, 2008 09:26
Location: Sweden

Postby gring » Fri Feb 13, 2009 19:43

I didn't have time to vote but we use VC9 in our project. I don't see any need for VC2003

/Gring


Return to “Official Announcements, Works in Progress, and Future Directions”

Who is online

Users browsing this forum: Google [Bot] and 2 guests