[SOLVED]CEImagesetEditor unexpected clipping issue

Use this forum for:
- Discussion regarding unofficial CEGUI related tools, scripts and utilities.
- User to user help for the obsoleted CELayoutEditor and CEImagesetEditor tools.

Moderators: CEGUI MVP, CEGUI Team

rockoz
Not too shy to talk
Not too shy to talk
Posts: 34
Joined: Tue Sep 22, 2009 02:26

[SOLVED]CEImagesetEditor unexpected clipping issue

Postby rockoz » Wed Jun 09, 2010 09:46

Hello there
Recently I worked on CEImagesetEditor.
And I met a strange clipping issue.

Two methods can make it happen:
1.Use mouse wheel to zoom in the imageset you've created. When either elastic box is partially outside the display window,
drag the window in order to make the box to show up. You'll see the box been clipped by sth., like this:

zoom in
Image

and drag right side of display window, box has been clipped...
Image

2.Use scroll bar to make the box outside display window as method 1, also can reproduce it.


And sth.is even stranger that after the box been clipped, move the scroll bar, the box will become back to normal... :(
I tried to solve this problem but only find during the change the gui sheet rendering surface has not redrawn.
If this is true, is that the OpenGL renderer to be blamed?

Anyone can help?
Last edited by rockoz on Sun Jun 13, 2010 04:01, edited 1 time in total.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: CEImagesetEditor unexpected clipping issue

Postby CrazyEddie » Wed Jun 09, 2010 17:46

I've moved this to CEGUI Related Tools.

There are a couple of potential reasons for this issue, and my final analyses will be dependent upon the questions below ;) It's extremely doubtful it has anything to do with the OpenGL renderer module.

So, if you could provide the answers to the following: Which operating system is this on? Did you use the binary version of the editor, or did you compile the code yourself? If you did compile the code yourself, which version of wxWidgets did you use?

Thanks,

CE.

rockoz
Not too shy to talk
Not too shy to talk
Posts: 34
Joined: Tue Sep 22, 2009 02:26

Re: CEImagesetEditor unexpected clipping issue

Postby rockoz » Thu Jun 10, 2010 01:48

Thank you CE :hammer:

Here is the info:
Platform:
WindowsXP SP3
Version of CEImagesetEditor:
Both binary and source, and for source I compiled both 0.6.2 and 0.7.1

What makes me nervous is that I wonder this issue could have sth. to do with this thread,
http://www.cegui.org.uk/phpBB2/viewtopic.php?f=1&t=4859
which will probably show up in further use of CEGUI

But after I tried all the methods you mentioned in it, this problem could not be solved.
So there maybe some other reason lead to thi issue. :?

PS: It seems working in different time zones makes conversation a little inconvenient. :pint:

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: CEImagesetEditor unexpected clipping issue

Postby CrazyEddie » Thu Jun 10, 2010 12:02

Thanks for the info, though you did forget to mention the wxWIdgets version :P I'll have a look over some things in the next day or so and get back to you when I have answers.

The issue in that other thread is something that's very specific for a given set of circumstances and is definitely not the cause of this issue in the editor - as evidenced by the fact you also had it in 0.6.2, where the issue in that other thread can not exist ever.

Anyhow, I have a couple of theories to check as to what I so think it could be.

PS: It seems working in different time zones makes conversation a little inconvenient.

Yeah, it certainly can represent a challenge ;)

CE.

rockoz
Not too shy to talk
Not too shy to talk
Posts: 34
Joined: Tue Sep 22, 2009 02:26

Re: CEImagesetEditor unexpected clipping issue

Postby rockoz » Thu Jun 10, 2010 13:50

Thanks for the info, though you did forget to mention the wxWIdgets version I'll have a look over some things in the next day or so and get back to you when I have answers.


Oops, I mistake some words... :oops:

I will check it in tomorrow. And I guess the version should be 2.8.10. :pint:

rockoz
Not too shy to talk
Not too shy to talk
Posts: 34
Joined: Tue Sep 22, 2009 02:26

Re: CEImagesetEditor unexpected clipping issue

Postby rockoz » Sat Jun 12, 2010 01:54

I confirmed my wxWidgets version do is 2.8.10, hope this will be helpful.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: CEImagesetEditor unexpected clipping issue

Postby CrazyEddie » Sat Jun 12, 2010 16:21

Thanks :)

I looked into this and after some initial confusion (don't worry, it's common :P), managed to reproduce the issue easily. This turned out to be a bug in the editor code and has been fixed in svn trunk for the editor.

Since the fix is so simple, I'll post it here too, in case you'd rather just apply that if you're not using the svn code:

Code: Select all

Index: src/EditorGLCanvas.cpp
===================================================================
--- src/EditorGLCanvas.cpp      (revision 2560)
+++ src/EditorGLCanvas.cpp      (revision 2561)
@@ -221,6 +221,7 @@
     changeSize( clientWidth, clientHeight );
 
     updateScrollbars();
+    computeZoomFactor(0);
 }
 
 //-----------------------------------------------------------------------


CE

rockoz
Not too shy to talk
Not too shy to talk
Posts: 34
Joined: Tue Sep 22, 2009 02:26

Re: CEImagesetEditor unexpected clipping issue

Postby rockoz » Sun Jun 13, 2010 04:01

Thank you CE :hammer:

It fix the problem. Maybe I should keep an eye on the svn trunk as well as new release.


Return to “Unofficial CEGUI-Related Tools”

Who is online

Users browsing this forum: No registered users and 0 guests