0.7.1's sample cannot run in OgreRenderer.[SOLVED]

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

harr999y
Just popping in
Just popping in
Posts: 8
Joined: Fri Apr 09, 2010 21:03

0.7.1's sample cannot run in OgreRenderer.[SOLVED]

Postby harr999y » Fri Apr 09, 2010 21:59

Hi,there.First say Hello to u~~ :D

My problem is:When I use the ogre renderer to show the sample(every one),it doesn't work. :(
Just after the constructor of CEGuiOgreBaseApplication,it comes the sampleApp->initialiseSample();
and then step into SchemeManager::getSingleton().create("TaharezLook.scheme");
next U xml_loader(xml_filename, resource_group);
....up to the fuction void ExpatParser::parseXMLFile(XMLHandler& handler, const String& filename, const String& /*schemaName*/, const String& resourceGroup); until the CEGUI::System::getSingleton().getResourceProvider()->loadRawDataContainer(filename, rawXMLData, resourceGroup); ok, continue step into.
Then

Code: Select all

void OgreResourceProvider::loadRawDataContainer(const String& filename,
                                                RawDataContainer& output,
                                                const String& resourceGroup)
{
    String orpGroup;
    if (resourceGroup.empty())
        orpGroup = d_defaultResourceGroup.empty() ?
            Ogre::ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME.c_str() :
            d_defaultResourceGroup;
    else
        orpGroup = resourceGroup;

    Ogre::DataStreamPtr input = Ogre::ResourceGroupManager::getSingleton().
        openResource(filename.c_str(), orpGroup.c_str());

    if (input.isNull())
        throw InvalidRequestException(
            "OgreCEGUIResourceProvider::loadRawDataContainer: Unable to open "
            "resource file '" + filename + "' in resource group '" + orpGroup +
            "'.");

    Ogre::String buf = input->getAsString();
    const size_t memBuffSize = buf.length();

    unsigned char* mem = new unsigned char[memBuffSize];
    memcpy(mem, buf.c_str(), memBuffSize);

    output.setData(mem);
    output.setSize(memBuffSize);
}


Here when I step out this function,then it's wrong!

Code: Select all

--- c:\users\harry\desktop\11\boost_1_42\boost\thread\win32\interlocked_read.hpp
#ifndef BOOST_THREAD_DETAIL_INTERLOCKED_READ_WIN32_HPP
#define BOOST_THREAD_DETAIL_INTERLOCKED_READ_WIN32_HPP

//  interlocked_read_win32.hpp
//
//  (C) Copyright 2005-8 Anthony Williams
//
//  Distributed under the Boost Software License, Version 1.0. (See
//  accompanying file LICENSE_1_0.txt or copy at
//  http://www.boost.org/LICENSE_1_0.txt)

#include <boost/detail/interlocked.hpp>

#include <boost/config/abi_prefix.hpp>

#ifdef BOOST_MSVC

extern "C" void _ReadWriteBarrier(void);
#pragma intrinsic(_ReadWriteBarrier)

namespace boost
{
    namespace detail
    {
        inline long interlocked_read_acquire(long volatile* x)
        {
663B14D0  push        ebp 
663B14D1  mov         ebp,esp
663B14D3  sub         esp,0CCh
663B14D9  push        ebx 
663B14DA  push        esi 
663B14DB  push        edi 
663B14DC  lea         edi,[ebp-0CCh]
663B14E2  mov         ecx,33h
663B14E7  mov         eax,0CCCCCCCCh
663B14EC  rep stos    dword ptr es:[edi]
            long const res=*x;
663B14EE  mov         eax,dword ptr [x]
663B14F1  mov         ecx,dword ptr [eax]
663B14F3  mov         dword ptr [res],ecx
            _ReadWriteBarrier();
            return res;
663B14F6  mov         eax,dword ptr [res]
        }

The arrow is here:
long const res=*x;
663B14EE mov eax,dword ptr [x]
663B14F1 mov ecx,dword ptr [eax]


And VC said:Unhandled exception at 0x663b14f1 (CEGUIOgreRenderer_d.dll) in Sample_FirstWindow_d.exe: 0xC0000005: Access violation reading location 0xccccccd0.

:cry: I really don't know why here comes an error,please help me! :(

The end part of CRGUI.log is:

Code: Select all

10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Slider' windows added. (07665058)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/Spinner' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Spinner' windows added. (07665218)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/TabButton' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/TabButton' windows added. (076653D8)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/TabControl' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/TabControl' windows added. (07665598)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/Thumb' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Thumb' windows added. (07665758)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/Titlebar' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Titlebar' windows added. (07665918)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/Tooltip' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Tooltip' windows added. (07665BC0)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/ItemListbox' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/ItemListbox' windows added. (07665D80)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/GroupBox' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/GroupBox' windows added. (07665F40)
10/04/2010 04:12:41 (Std)    Created WindowFactory for 'CEGUI/Tree' windows.
10/04/2010 04:12:41 (Std)    WindowFactory for 'CEGUI/Tree' windows added. (07666100)
10/04/2010 04:12:41 (Std)    Window type alias named 'DefaultGUISheet' added for window type 'DefaultWindow'.
10/04/2010 04:12:41 (Std)    CEGUI::System singleton created. (0107D768)
10/04/2010 04:12:41 (Std)    ---- CEGUI System initialisation completed ----
10/04/2010 04:12:41 (Std)    

No useful information...

Anyone knows it?
:?: :?: Thank U~~ :)
Last edited by harr999y on Tue Apr 13, 2010 08:46, edited 1 time in total.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: A terrible error:0.7.1's sample cannot run in OgreRenderer..

Postby CrazyEddie » Mon Apr 12, 2010 09:07

I've no idea about the issue.

And please, do not cut off the part of the log that explicitly says you have to post that part on the forum. WTF is wrong with you people?!

CE.

harr999y
Just popping in
Just popping in
Posts: 8
Joined: Fri Apr 09, 2010 21:03

Re: A terrible error:0.7.1's sample cannot run in OgreRenderer..

Postby harr999y » Tue Apr 13, 2010 08:45

CrazyEddie wrote:I've no idea about the issue.

And please, do not cut off the part of the log that explicitly says you have to post that part on the forum. WTF is wrong with you people?!

CE.


:?: I really don't know why u are so angry. :( WTF meaning of "do not cut off the part of the log that explicitly says you have to post that part on the forum"??
I post the part of log is just want to give u more info,I don't explicitly say I have to!

And the error is just because when I compile them I use the latest Ogre with the 0.7.1 which is before.Your post about the new SDK helps me,Thank u! :)

Harry

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: 0.7.1's sample cannot run in OgreRenderer.[SOLVED]

Postby CrazyEddie » Thu Apr 15, 2010 08:36

The point is - or was - that the log contains a part that starts with this:

Code: Select all

27/03/2010 11:47:52 (Std)    ********************************************************************************
27/03/2010 11:47:52 (Std)    * Important:                                                                   *
27/03/2010 11:47:52 (Std)    *     To get support at the CEGUI forums, you must post _at least_ the section *
27/03/2010 11:47:52 (Std)    *     of this log file indicated below.  Failure to do this will result in no  *
27/03/2010 11:47:52 (Std)    *     support being given; please do not waste our time.                       *
27/03/2010 11:47:52 (Std)    ********************************************************************************

and is followed by some information that I would prefer to see posted with every query and is the reason the above notice was added to the log. The above notice was not added for comedic effect or because it made me feel like a man, no, the notice was added in order that I would be able to more quickly and readily be able to help people.

Now, I can't but wonder about the mentality of people who, having seen the above notice, then decide to consciously and deliberately remove this piece of the log before posting what they consider to be the 'important' bit. Well here's a clue for you - since you came here for help, and therefore do not know what the cause of some particular issue is, you have no intellectual authority to make a judgement as to what parts of the log are or are not important, and so should be posting all of it regardless.

CE.

harr999y
Just popping in
Just popping in
Posts: 8
Joined: Fri Apr 09, 2010 21:03

Re: 0.7.1's sample cannot run in OgreRenderer.[SOLVED]

Postby harr999y » Thu Apr 15, 2010 16:23

CrazyEddie wrote:The point is - or was - that the log contains a part that starts with this:

Code: Select all

27/03/2010 11:47:52 (Std)    ********************************************************************************
27/03/2010 11:47:52 (Std)    * Important:                                                                   *
27/03/2010 11:47:52 (Std)    *     To get support at the CEGUI forums, you must post _at least_ the section *
27/03/2010 11:47:52 (Std)    *     of this log file indicated below.  Failure to do this will result in no  *
27/03/2010 11:47:52 (Std)    *     support being given; please do not waste our time.                       *
27/03/2010 11:47:52 (Std)    ********************************************************************************

and is followed by some information that I would prefer to see posted with every query and is the reason the above notice was added to the log. The above notice was not added for comedic effect or because it made me feel like a man, no, the notice was added in order that I would be able to more quickly and readily be able to help people.

Now, I can't but wonder about the mentality of people who, having seen the above notice, then decide to consciously and deliberately remove this piece of the log before posting what they consider to be the 'important' bit. Well here's a clue for you - since you came here for help, and therefore do not know what the cause of some particular issue is, you have no intellectual authority to make a judgement as to what parts of the log are or are not important, and so should be posting all of it regardless.

CE.


I'm very sorry,CE. :( I didn't see the notice as I'm just new for the CEGUI,and new for here.
And Thanks for your remind,next time I will notice it. :)

hmxp8
Just popping in
Just popping in
Posts: 2
Joined: Sat Nov 20, 2010 14:33

Re: 0.7.1's sample cannot run in OgreRenderer.[SOLVED]

Postby hmxp8 » Sun Nov 21, 2010 07:23

OMG...
I face the same question...
And I use VS08+DX08Feb+Ogre1.7.1+CeGUI0.7.1,
what does "And the error is just because when I compile them I use the latest Ogre with the 0.7.1 which is before.Your post about the new SDK helps me..."mean?
I download CeGUI0.7.4,and still all the same,because of the broken heap...
Now I'm in desperate waiting the download bar of 0.7.5 ~~~~~
I need your help~Thank you!

hmxp8
Just popping in
Just popping in
Posts: 2
Joined: Sat Nov 20, 2010 14:33

Re: 0.7.1's sample cannot run in OgreRenderer.[SOLVED]

Postby hmxp8 » Sun Nov 21, 2010 09:05

Thank to the God~
When I recomplied the Ogre1.7.2 & CeGUI 0.7.5,
all things get well~
Through it spend my three days,but I'm proud of not giving up!
It's not my fault,hu...


Return to “Help”

Who is online

Users browsing this forum: No registered users and 8 guests