[CMake] Problems finding dependencies

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

maltazar1
Just popping in
Just popping in
Posts: 2
Joined: Sun Oct 19, 2014 15:27

[CMake] Problems finding dependencies

Postby maltazar1 » Sun Oct 19, 2014 15:35

So, I'm compiling CEGUI 0.8.4, I've compiled depencendies (side note: update your dependencies for win zip, it's outdated) from bitbucket, since they have a fix for them not compiling correctly under Mingw32, which I'm using.
The thing is, that when trying to compile CEGUI, CMake cannot find dependencies, even though they're properly built (both debug/release in static and shared flavor).
So, my question is, where do I put the dependencies or how do I point CMake to their whereabouts so I can finally move on to working in this amazing lib?

I've tried putting the dependencies folder in root of cegui-0.8.4, but that didn't work, any other ideas?
This is my current CMake log

Code: Select all

Could NOT find PCRE (missing:  PCRE_LIB)
Could NOT find FREETYPE (missing:  FREETYPE_LIB)
Could NOT find MINIZIP (missing:  MINIZIP_LIB)
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
Could NOT find FRIBIDI (missing:  FRIBIDI_FOUND_ALL_LIBS FRIBIDI_INCLUDE_DIR)
Could NOT find GLEW (missing:  GLEW_LIB)
Could NOT find GLFW (missing:  GLFW_LIB)
Could NOT find DIRECTXSDK (missing:  DIRECTXSDK_LIB_PATH DIRECTXSDK_H_PATH DIRECTXSDK_MAX_D3D)
Could NOT find D3DX11EFFECTS (missing:  D3DX11EFFECTS_LIB D3DX11EFFECTS_H_PATH)
Could NOT find IRRLICHT (missing:  IRRLICHT_LIB IRRLICHT_H_PATH)
Could NOT find OGRE (missing:  OGRE_LIB OGRE_H_PATH OGRE_H_BUILD_SETTINGS_PATH)
Could NOT find OIS (missing:  OIS_LIB OIS_H_PATH)
Could NOT find DIRECTFB (missing:  DIRECTFB_LIB DIRECTFB_H_PATH)
Could NOT find OPENGLES (missing:  OPENGLES_LIB OPENGLES_H_PATH)
Could NOT find EXPAT (missing:  EXPAT_LIB)
Could NOT find XERCESC (missing:  XERCESC_LIB XERCESC_H_PATH)
Could NOT find LibXml2 (missing:  LIBXML2_INCLUDE_DIR)
Could NOT find TINYXML (missing:  TINYXML_LIB)
Could NOT find RAPIDXML (missing:  RAPIDXML_H_PATH)
Could NOT find IL (missing:  IL_LIB IL_H_PATH)
Could NOT find ILU (missing:  ILU_LIB)
Could NOT find FREEIMAGE (missing:  FREEIMAGE_LIB)
Could NOT find SILLY (missing:  SILLY_LIB)
Could NOT find CORONA (missing:  CORONA_LIB)
Could NOT find PVRTOOLS (missing:  PVRTOOLS_LIB PVRTOOLS_H_PATH)
Could NOT find LUA51 (missing:  LUA_LIB)
Could NOT find TOLUAPP (missing:  TOLUAPP_LIB)
Could NOT find Boost
Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE)
Could NOT find FREETYPE (missing:  FREETYPE_LIB)
Some or all of the gtk libraries were not found. (missing:  GTK2_GTK_LIBRARY GTK2_GTK_INCLUDE_DIR GTK2_GDK_INCLUDE_DIR GTK2_GDKCONFIG_INCLUDE_DIR GTK2_GDK_LIBRARY GTK2_GLIB_INCLUDE_DIR GTK2_GLIBCONFIG_INCLUDE_DIR GTK2_GLIB_LIBRARY)
CMake Warning at CMakeLists.txt:340 (message):
  None of the XML parser modules are going to be built.

  You should ensure that CEGUI_OPTION_DEFAULT_XMLPARSER is set to something

  appropriate.


CMake Warning at CMakeLists.txt:382 (message):
  None of the image codec modules are going to be built.

  You should ensure that CEGUI_OPTION_DEFAULT_IMAGECODEC is set to something

  appropriate.


Configuring done

lucebac
Just can't stay away
Just can't stay away
Posts: 193
Joined: Sat May 24, 2014 21:55

Re: [CMake] Problems finding dependencies

Postby lucebac » Sun Oct 19, 2014 21:58


maltazar1
Just popping in
Just popping in
Posts: 2
Joined: Sun Oct 19, 2014 15:27

Re: [CMake] Problems finding dependencies

Postby maltazar1 » Mon Oct 20, 2014 13:12

maltazar1 wrote:I've tried putting the dependencies folder in root of cegui-0.8.4, but that didn't work, any other ideas?

lucebac
Just can't stay away
Just can't stay away
Posts: 193
Joined: Sat May 24, 2014 21:55

Re: [CMake] Problems finding dependencies

Postby lucebac » Mon Oct 20, 2014 13:42

maltazar1 wrote: (both debug/release in static and shared flavor).

Avoid static linking where possible!
Can you please clean your deps/build folder and rebuild the deps only as shared libs but both in debug and release mode?

User avatar
Kulik
CEGUI Team
Posts: 1382
Joined: Mon Jul 26, 2010 18:47
Location: Czech Republic
Contact:

Re: [CMake] Problems finding dependencies

Postby Kulik » Mon Oct 20, 2014 16:59

You need to place the built dependencies folder there, not the source folder.

You can also place it wherever you please and set the paths manually if you for example use the libraries in your project already.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 23 guests