Performance

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

xabila
Quite a regular
Quite a regular
Posts: 55
Joined: Tue Mar 10, 2009 09:39
Location: Bruxelles

Performance

Postby xabila » Sun Jun 07, 2009 08:19

hi,
I was wondering if 5000 triangles to display my GUI is normal, or if i have done something wrong.
For example, a simple tooltip is adding 50 triangles.
But maybe every character is displayed by a quad, wich can explain everything...

Thanks

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: Performance

Postby CrazyEddie » Sun Jun 07, 2009 15:59

xabila wrote:maybe every character is displayed by a quad, wich can explain everything...

Yes, this is currently the case.

CE.

xabila
Quite a regular
Quite a regular
Posts: 55
Joined: Tue Mar 10, 2009 09:39
Location: Bruxelles

Re: Performance

Postby xabila » Mon Jun 08, 2009 07:36

Ok thanks, is the same on the new release ?
Thanks

dredogol
Not too shy to talk
Not too shy to talk
Posts: 41
Joined: Sat Apr 18, 2009 20:43

Re: Performance

Postby dredogol » Mon Jun 22, 2009 20:05

From what I'm understand about the next release (0.7.x), it will no longer render each character (letter) as 2-triangles, because of caching.

Instead, the TEXT area of the GUI should be rendered as just 2-triangles, instead of many tiny ones.


Return to “Help”

Who is online

Users browsing this forum: Bing [Bot] and 16 guests