IMPORTANT: MSVC++ users on the SVN v0-7 branch and trunk

Official announcements from the CEGUI project.

Moderator: CEGUI Team

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

IMPORTANT: MSVC++ users on the SVN v0-7 branch and trunk

Postby CrazyEddie » Fri Oct 09, 2009 12:48

Hi,

This announcement only really affects users of MSVC++ who are using the code in the v0-7 branch or trunk of subversion.

In order to resolve issues in the statically linked version of CEGUI (mainly to use the statically linked C/C++ runtime - with the /MT and /MTd options), we have issued updated dependency packs and updated the premake solution generation scripts to use the correct settings and take advantage of the new dependencies. The upshot of all this is that the dependency pack layout has changed and so when using the latest code from the v0-7 branch, you will need to use the new dependency packs.

Download links:
CEGUI 0.7.x (Revision 1) precompiled dependencies for MSVC++ 2008 (.zip file)
CEGUI 0.7.x (Revision 1) precompiled dependencies for MSVC++ 2005 (must have SP1) (.zip file)
CEGUI 0.7.x (Revision 1) precompiled dependencies for MSVC++ 2003 (.zip file)

We apologise for having to make such a change to the 'stable' branch, but it was important that this issue did not persist for the lifetime of the 0.7.x series of releases.

On behalf of The CEGUI Team.

Return to “Official Announcements, Works in Progress, and Future Directions”

Who is online

Users browsing this forum: No registered users and 0 guests