Running in fullscreen

For help with general CEGUI usage:
- Questions about the usage of CEGUI and its features, if not explained in the documentation.
- Problems with the CMAKE configuration or problems occuring during the build process/compilation.
- Errors or unexpected behaviour.

Moderators: CEGUI MVP, CEGUI Team

Nomonkeybusiness
Not too shy to talk
Not too shy to talk
Posts: 45
Joined: Wed Sep 09, 2009 11:20

Running in fullscreen

Postby Nomonkeybusiness » Wed Dec 02, 2009 11:55

Hi!
Our project is approaching deadline, and the time has come to make sure that the game looks good, not only in windowed mode.
My problem is that the gui seems to be blurred when running fullscreen-mode.
What do you people think would be the best approach here? Should I make separate .layouts for my gui for windowed mode/fullscreen mode?
Discuss

Jamarr
CEGUI MVP
CEGUI MVP
Posts: 812
Joined: Tue Jun 03, 2008 23:59
Location: USA

Re: Running in fullscreen

Postby Jamarr » Wed Dec 02, 2009 16:36

It's difficult to know what is causing the problem when you do not provide any details; comparison images would be nice. I have serious doubts about the only difference being windowed vs fullscreen - I bet you are running a higher resolution when you switch to fullscreen?

If I had to guess why it looks blurred, I would assume that you have setup CEGUI to 'autoscale' from the native resolution to the active resolution? To prevent autoscaling, use fixed-offsets instead of scaled-offsets in your layouts and set the AutoScaled property to False on your imagesets and fonts.
If somebody helps you by replying to your thread, upvote him/her as a thanks! Make sure to include your CEGUI.log and everything you tried when posting! And remember that we are not magicians!

NotNullGothic
Just popping in
Just popping in
Posts: 6
Joined: Mon Mar 01, 2010 20:17

Re: Running in fullscreen

Postby NotNullGothic » Sun Mar 07, 2010 15:22

I compiled SampleDemo_6 for Debug and Release targets, it works perfect except for the Fullscren mode for any of the API I'm using (D3D9 OpenGL in Ogre). It closes correctly but my desktop taskbar is modified. I am running in Win7 x64. I'll try to test it in WinXP, but is there anyway to fix this issue? Is it a known problem?
Last edited by NotNullGothic on Sun Mar 07, 2010 16:07, edited 1 time in total.

NotNullGothic
Just popping in
Just popping in
Posts: 6
Joined: Mon Mar 01, 2010 20:17

Re: Running in fullscreen

Postby NotNullGothic » Sun Mar 07, 2010 16:05

Confirmed, it is a Win7 issue, in WinXP works perfect for Release or Debug.
Update: after a reboot the behavior remains in WinXP.
    Windowned mode for release: OpenGL and D3D9 open, run, close no problems
    Fullscreen mode: it opens, runs but sends a crashing message while closing and affects the whole taskbar
    For debug targets the application can't be even opened.

The CEGUI.log reports a successful event:

Code: Select all

08/03/2010 10:24:59 (Std)    ---- CEGUI System destruction completed ----
08/03/2010 10:24:59 (Std)    CEGUI::Logger singleton destroyed. (026651C0)


The CEGUI Console displays
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: Running in fullscreen

Postby CrazyEddie » Sun Mar 07, 2010 18:17

Hi,

Thanks for raising the issue, but please post the indicated section in the CEGUI.log file. I know it might seem ridiculous that I keep asking for this, but it contains information I need; without this information I am unable to reliably test these issues.

Thanks,

CE.

NotNullGothic
Just popping in
Just popping in
Posts: 6
Joined: Mon Mar 01, 2010 20:17

Re: Running in fullscreen

Postby NotNullGothic » Mon Mar 08, 2010 20:15

Np here is the file, just in case i'll give you the ogre.log too.
CEGUI log http://uploader.polorix.net//files/273/CEGUI.log
Ogre log http://uploader.polorix.net//files/273/Ogre.log

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: Running in fullscreen

Postby CrazyEddie » Tue Mar 09, 2010 09:35

Thanks for posting the logs, I'll test it out and get back to you ASAP.

CE.

User avatar
CrazyEddie
CEGUI Project Lead
Posts: 6760
Joined: Wed Jan 12, 2005 12:06
Location: England
Contact:

Re: Running in fullscreen

Postby CrazyEddie » Tue Mar 09, 2010 10:26

Ok, this turned out to be a small bug in our samples base app for Ogre; basically it was trying to notify the CEGUI::System object of the change in display size after the CEGUI::System had already been destroyed. This is fixed in branches/v0-7 @ r2461.

Thanks again,

CE.


Return to “Help”

Who is online

Users browsing this forum: No registered users and 9 guests